summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadim Sückr2020-01-15 11:13:36 +0100
committerRadim Sückr2020-01-15 11:13:36 +0100
commit9448870e4c8e3707eade58f0c6501fca5f67979a (patch)
treed18bab14dbacf69088767388d734aeee5e693c50
downloadaur-9448870e4c8e3707eade58f0c6501fca5f67979a.tar.gz
First release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6d9366558cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-togglpy
+ pkgdesc = A hosts file manager library written in python
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/matthewdowney/TogglPy
+ arch = any
+ license = MIT
+ source = git+https://github.com/matthewdowney/TogglPy.git
+ sha512sums = SKIP
+
+pkgname = python-togglpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9ce6a39786f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Radim Sückr <contact@radimsuckr.cz>
+
+pkgname=python-togglpy
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='A hosts file manager library written in python'
+arch=('any')
+url='https://github.com/matthewdowney/TogglPy'
+license=('MIT')
+source=('git+https://github.com/matthewdowney/TogglPy.git')
+sha512sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+}