summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-05-12 21:44:21 +0800
committerChih-Hsuan Yen2022-05-12 21:44:21 +0800
commit7281798208c92e1cdbf7866d3114813929c22fd8 (patch)
tree76236edb80881c3a0c9a3f1bc14924ac062fd375
parentd16d17d4833ea14613757cb0e6cd52ac4081bd37 (diff)
downloadaur-7281798208c92e1cdbf7866d3114813929c22fd8.tar.gz
Temporarily disables CUDA until it builds with GCC 12
Also fix incorrect arch= detected by namcap: * python-torchaudio E: ELF file ('usr/lib/python3.10/site-packages/torchaudio/_torchaudio.so') found in an 'any' package. * python-torchaudio E: ELF file ('usr/lib/python3.10/site-packages/torchaudio/lib/libtorchaudio.so') found in an 'any' package.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8d1fa628ada..faa9c0ae341b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,8 @@ pkgbase = python-torchaudio
pkgver = 0.11.0
pkgrel = 1
url = https://github.com/pytorch/audio
- arch = any
+ arch = x86_64
+ arch = i686
license = BSD
makedepends = git
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 5963b1e0f5d4..5ffee11fbae7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=audio
pkgver=0.11.0
pkgrel=1
pkgdesc="Data manipulation and transformation for audio signal processing, powered by PyTorch"
-arch=('any')
+arch=('x86_64' 'i686')
url="https://github.com/pytorch/audio"
license=('BSD')
depends=('python' 'python-pytorch')
@@ -16,6 +16,9 @@ conflicts=('python-torchaudio-git')
source=("git+$url#tag=v${pkgver}")
sha512sums=('SKIP')
+# Temporarily disable CUDA as it does not build with GCC 12
+export USE_CUDA=0
+
prepare() {
cd "$srcdir/${_pkgname}"
# Use sourceforge url to fetch zlib