summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-14 08:56:17 +1200
committercaltlgin2020-08-14 08:56:17 +1200
commit642704edb13787e08e3f995aef8399b12b87aae0 (patch)
treef9d4339aa8ca786497d9cb19f1a2c0985d64729d
parent76c8e2a9f1a6b8a54dcb272216b4dac6dd5e28ee (diff)
downloadaur-642704edb13787e08e3f995aef8399b12b87aae0.tar.gz
Adopt PKGBUILD. Add README
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2624d254bc42..3bef0e79ec10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-torrequest
pkgdesc = Simple Python interface for HTTP(s) requests over Tor
pkgver = 0.1.0
- pkgrel = 1
- url = https://pypi.org/project/torrequest
+ pkgrel = 2
+ url = https://github.com/erdiaker/torrequest
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
depends = python-pysocks
depends = python-requests
depends = python-stem
- source = https://files.pythonhosted.org/packages/a3/d2/00538e47a2c80979231313c346a0abc3927c7b230d69eb923bb5b221ec62/torrequest-0.1.0.tar.gz
+ provides = torrequest
+ source = https://files.pythonhosted.org/packages/source/t/torrequest/torrequest-0.1.0.tar.gz
+ source = torrequest-0.1.0-README.md::https://raw.githubusercontent.com/erdiaker/torrequest/master/README.md
sha256sums = 3745d4ea3ffda98d7a034363c787adb37aab77bdab40094a4d937392cd4dae82
+ sha256sums = SKIP
pkgname = python-torrequest
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 0fe2ffbd3674..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,5 +0,0 @@
-*.log
-pkg/
-src/
-*.pkg.tar.xz
-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 94f5694d5b87..5c8cd1a7a938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: peeweep <peeweep at 0x0 dot ee>
-pkgname=python-torrequest
_pkgname=torrequest
+pkgname=python-${_pkgname}
pkgver=0.1.0
-pkgrel=1
-pkgdesc="Simple Python interface for HTTP(s) requests over Tor"
+pkgrel=2
+pkgdesc='Simple Python interface for HTTP(s) requests over Tor'
arch=('any')
-url="https://pypi.org/project/torrequest"
+url='https://github.com/erdiaker/torrequest'
+_rawurl="https://raw.githubusercontent.com/${url##*github.com/}"
license=('MIT')
+# No licence file available upstream
depends=('python' 'python-pysocks' 'python-requests' 'python-stem')
-source=("https://files.pythonhosted.org/packages/a3/d2/00538e47a2c80979231313c346a0abc3927c7b230d69eb923bb5b221ec62/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('3745d4ea3ffda98d7a034363c787adb37aab77bdab40094a4d937392cd4dae82')
+makedepends=('python-setuptools')
+provides=("${_pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "${_pkgname}-${pkgver}-README.md::${_rawurl}/master/README.md")
+sha256sums=('3745d4ea3ffda98d7a034363c787adb37aab77bdab40094a4d937392cd4dae82'
+ 'SKIP')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 "${_pkgname}-${pkgver}-README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: