summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:35:28 +1300
committercaltlgin2020-12-03 09:35:28 +1300
commit7b5d0e50e17c6af5284a550806261e3bd5ef93eb (patch)
treefd217269839ea048cced4756767a1fa99ee63395
parent642704edb13787e08e3f995aef8399b12b87aae0 (diff)
downloadaur-7b5d0e50e17c6af5284a550806261e3bd5ef93eb.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bef0e79ec10..2cc3171bb608 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = python-torrequest
pkgdesc = Simple Python interface for HTTP(s) requests over Tor
pkgver = 0.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/erdiaker/torrequest
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
depends = python-pysocks
depends = python-requests
depends = python-stem
- provides = torrequest
source = https://files.pythonhosted.org/packages/source/t/torrequest/torrequest-0.1.0.tar.gz
- source = torrequest-0.1.0-README.md::https://raw.githubusercontent.com/erdiaker/torrequest/master/README.md
+ source = torrequest-readme-6cc228cd460dd119e053cf2168b94120be5c98d4::https://github.com/erdiaker/torrequest/raw/6cc228cd460dd119e053cf2168b94120be5c98d4/README.md
sha256sums = 3745d4ea3ffda98d7a034363c787adb37aab77bdab40094a4d937392cd4dae82
- sha256sums = SKIP
+ sha256sums = 820c985c4c1e943d35b92091c7b07c68ec7a45bb93b21e2881a09f976fbe6df2
pkgname = python-torrequest
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 5c8cd1a7a938..d62513062945 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: peeweep <peeweep at 0x0 dot ee>
-_pkgname=torrequest
-pkgname=python-${_pkgname}
+_pkgname='torrequest'
+pkgname="python-${_pkgname}"
+
pkgver=0.1.0
-pkgrel=2
+pkgrel=3
+_commit_readme='6cc228cd460dd119e053cf2168b94120be5c98d4'
+
pkgdesc='Simple Python interface for HTTP(s) requests over Tor'
arch=('any')
url='https://github.com/erdiaker/torrequest'
-_rawurl="https://raw.githubusercontent.com/${url##*github.com/}"
+_url_pypi='https://pypi.org/project/torrequest'
license=('MIT')
# No licence file available upstream
-depends=('python' 'python-pysocks' 'python-requests' 'python-stem')
+depends=('python-pysocks' 'python-requests' 'python-stem')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "${_pkgname}-${pkgver}-README.md::${_rawurl}/master/README.md")
+ "${_pkgname}-readme-${_commit_readme}::${url}/raw/${_commit_readme}/README.md")
sha256sums=('3745d4ea3ffda98d7a034363c787adb37aab77bdab40094a4d937392cd4dae82'
- 'SKIP')
+ '820c985c4c1e943d35b92091c7b07c68ec7a45bb93b21e2881a09f976fbe6df2')
build() {
cd "${_pkgname}-${pkgver}"
@@ -25,7 +27,7 @@ build() {
}
package() {
- install -Dm644 "${_pkgname}-${pkgver}-README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dvm644 "${_pkgname}-readme-${_commit_readme}" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}