summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2020-05-09 00:52:46 +0200
committerJonas Witschel2020-05-09 00:52:46 +0200
commit4016eab95bfa78ae6bb510fd66cd87056d45681a (patch)
tree93a9a3c1844297ec8c4b000b73bd2f073cad0006
parent2cfee5dc7493afc3e32ea35b2a8503970e1f2b31 (diff)
downloadaur-4016eab95bfa78ae6bb510fd66cd87056d45681a.tar.gz
upgpkg: python-tpm2-pytss 0.1.5-1: upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 825639990915..e4c1b5dd4d4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tpm2-pytss
pkgdesc = Python bindings for tpm2-tss
- pkgver = 0.1.3
+ pkgver = 0.1.5
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-pytss
arch = x86_64
@@ -10,8 +10,10 @@ pkgbase = python-tpm2-pytss
makedepends = swig
depends = python-setuptools
depends = tpm2-tss
- source = https://files.pythonhosted.org/packages/source/t/tpm2-pytss/tpm2-pytss-0.1.3.tar.gz
- sha256sums = a9c21368275a0e058424131b03acb67d914c0f2419cccc66a4a1c0d9706a05b9
+ source = https://files.pythonhosted.org/packages/source/t/tpm2-pytss/tpm2-pytss-0.1.5.tar.gz
+ source = https://raw.githubusercontent.com/tpm2-software/tpm2-pytss/ad4c2a961135a069ba86410e1236162a9071e66b/examples/fapi_get_random.py
+ sha256sums = fb68f3f47ffe9fe365d3fd1e832b5c0568e21c0c962487cca5de50acdda6b181
+ sha256sums = 648beb5331a8c905e276c62fca3ea2e3231fa3c011a8ff277b69344ede3c4761
pkgname = python-tpm2-pytss
diff --git a/PKGBUILD b/PKGBUILD
index f15ae2a5e33b..fd244bac21e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
pkgname=python-tpm2-pytss
_name=${pkgname#python-}
-pkgver=0.1.3
+pkgver=0.1.5
pkgrel=1
pkgdesc='Python bindings for tpm2-tss'
arch=('x86_64')
@@ -10,8 +10,18 @@ license=('BSD')
depends=('python-setuptools' 'tpm2-tss')
makedepends=('swig')
checkdepends=('ibm-sw-tpm2' 'python-cryptography')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('a9c21368275a0e058424131b03acb67d914c0f2419cccc66a4a1c0d9706a05b9')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ 'https://raw.githubusercontent.com/tpm2-software/tpm2-pytss/ad4c2a961135a069ba86410e1236162a9071e66b/examples/fapi_get_random.py')
+sha256sums=('fb68f3f47ffe9fe365d3fd1e832b5c0568e21c0c962487cca5de50acdda6b181'
+ '648beb5331a8c905e276c62fca3ea2e3231fa3c011a8ff277b69344ede3c4761')
+
+prepare() {
+ cd "$_name-$pkgver"
+ # Add missing file required by the test suite
+ # (https://github.com/tpm2-software/tpm2-pytss/pull/32)
+ mkdir examples
+ cp "$srcdir/fapi_get_random.py" -t examples
+}
build() {
cd "$_name-$pkgver"