summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-05-15 12:34:03 -0600
committerMark Wagie2021-05-15 12:34:03 -0600
commit91b69a47f0507b9737f9dbd71113cd1a0bde59bd (patch)
treea61eb14a78f0d6ac652d7e73d6c62440e95cbe75
downloadaur-91b69a47f0507b9737f9dbd71113cd1a0bde59bd.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1d3a4072db5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-tr
+ pkgdesc = A Pure-Python implementation of the tr algorithm
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/ikegami-yukino/python-tr
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/p/python-tr/python-tr-0.1.2.tar.gz
+ sha256sums = 705630c5abd4bfc46e5e799b1002529137b56f730baceffe19a25acc4a9377d5
+
+pkgname = python-tr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64fd789e1107
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-tr
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A Pure-Python implementation of the tr algorithm"
+arch=('any')
+url="https://github.com/ikegami-yukino/python-tr"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('705630c5abd4bfc46e5e799b1002529137b56f730baceffe19a25acc4a9377d5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}