summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Gehr2023-05-21 00:26:26 +0200
committerStefan Gehr2023-05-21 00:26:26 +0200
commite6087ecfc6aedc6f30b9f23cf8e307f9a5fee904 (patch)
treec57c64f22d2cc3a61cedbb62b9be72ce5d818091
downloadaur-e6087ecfc6aedc6f30b9f23cf8e307f9a5fee904.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9f4a1879a53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-tr064
+ pkgdesc = Lightweight and Straight-Forward TR-064 Client
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/bfueldner/tr064
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-pip
+ depends = python-requests
+ depends = python-lxml
+ source = git+https://github.com/bfueldner/tr064#commit=6b12f879fa5ccec4cd2d68fac48db1c2815f131c
+ b2sums = SKIP
+
+pkgname = python-tr064
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..90d596482ab6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1c4b7b1ce73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Stefan Gehr <stefangehr@protonmail.com>
+
+_name=tr064
+pkgname=python-tr064
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Lightweight and Straight-Forward TR-064 Client"
+arch=(any)
+url="https://github.com/bfueldner/tr064"
+license=(MIT)
+depends=(python-requests python-lxml)
+makedepends=(git python-pip)
+source=(git+"https://github.com/bfueldner/tr064#commit=6b12f879fa5ccec4cd2d68fac48db1c2815f131c")
+b2sums=("SKIP")
+
+build() {
+ cd $_name
+ python setup.py build
+}
+
+package() {
+ cd $_name
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}