summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-04-11 14:25:03 +0200
committerPhilip Goto2020-04-11 14:25:03 +0200
commitfd5586340c143e1dfd00963cf1f7ff6ab5c48e35 (patch)
tree7646558744b27524a8025c87ab246e7e66addaa1
downloadaur-fd5586340c143e1dfd00963cf1f7ff6ab5c48e35.tar.gz
Initialize
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ab7cd755213
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-traces
+ pkgdesc = Python library for unevenly-spaced time series analysis
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://pypi.org/project/traces/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-infinity
+ source = https://github.com/datascopeanalytics/traces/archive/0788ff2cc863c026226f240352fcdfb04634afe5.tar.gz
+ sha256sums = SKIP
+
+pkgname = python-traces
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7cadb36208e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-traces
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Python library for unevenly-spaced time series analysis"
+url="https://pypi.org/project/traces/"
+depends=(python-infinity)
+makedepends=(python-setuptools)
+license=(MIT)
+arch=(any)
+_commit=0788ff2cc863c026226f240352fcdfb04634afe5
+source=("https://github.com/datascopeanalytics/traces/archive/${_commit}.tar.gz")
+sha256sums=(SKIP)
+
+build() {
+ cd "traces-${_commit}"
+ python setup.py build
+}
+
+package() {
+ cd "traces-${_commit}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -D LICENSE "${pkgdir}/usr/share/licenses/python-traces/LICENSE"
+}