summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Smidt2020-04-30 07:59:12 -0600
committerJoseph Smidt2020-04-30 07:59:12 -0600
commitd058a959d58dcb2adb5fbe44bd49c9114ed1ff53 (patch)
treeea03a0614d1083afdfb627e3fad7961a496647b3
downloadaur-d058a959d58dcb2adb5fbe44bd49c9114ed1ff53.tar.gz
Iniial commit starting with version 1.11.7
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6bbdca82148
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-trading_calendars
+ pkgdesc = A Python library of exchange calendars meant to be used with Zipline.
+ pkgver = 1.11.7
+ pkgrel = 1
+ url = https://github.com/quantopian/trading_calendars
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-dateutil
+ depends = python-pytz
+ depends = python-logbook
+ depends = python-toolz
+ source = python-trading_calendars-1.11.7.tar.gz::https://github.com/quantopian/trading_calendars/archive/1.11.7.tar.gz
+ sha256sums = e11d5b1927f0911dba1efa83b7cc04103b5ece5e4d658a5d8c286b1aaa35599f
+
+pkgname = python-trading_calendars
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0d2c5e86cf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Joseph Smidt <josephsmidt@gmail.com>
+
+_pkgname=trading_calendars
+pkgname=python-$_pkgname
+pkgver=1.11.7
+pkgrel=1
+pkgdesc="A Python library of exchange calendars meant to be used with Zipline."
+arch=('any')
+url="https://github.com/quantopian/trading_calendars"
+license=('APACHE')
+depends=('python-matplotlib' 'python-numpy' 'python-pandas'
+ 'python-dateutil' 'python-pytz' 'python-logbook' 'python-toolz')
+makedepends=('python-setuptools')
+source=($pkgname-$pkgver.tar.gz::"$url/archive/$pkgver.tar.gz")
+sha256sums=('e11d5b1927f0911dba1efa83b7cc04103b5ece5e4d658a5d8c286b1aaa35599f')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" -O1 --skip-build
+}