summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-09-22 16:09:31 -0400
committerGuillaume Horel2021-09-22 16:09:31 -0400
commit4e51d0b35594c76c43c979d7f312d405c023d1ab (patch)
treeee54e7b646956035c2c1819b5777de493441d305
parent249a3d1609839ff42e6ec9b219c2400950c92c78 (diff)
downloadaur-4e51d0b35594c76c43c979d7f312d405c023d1ab.tar.gz
move to current master
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f68c29231e6e..ae5e7c529303 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = python-traittypes
pkgdesc = Traitlet types for NumPy, SciPy and friends.
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jupyter-widgets/traittypes
arch = any
license = BSD
checkdepends = python-pytest
checkdepends = python-xarray
+ makedepends = git
makedepends = python-setuptools
depends = python
depends = python-traitlets
depends = python-numpy
depends = python-pandas
- source = https://github.com/jupyter-widgets/traittypes/archive/0.2.1.tar.gz
- sha256sums = f498c418d04551ea3b21fd97d1f3dcfbc114a672231580bb4e044a188f46efeb
+ source = git+https://github.com/jupyter-widgets/traittypes.git#commit=af2ebeec9e58b73a12d4cf841bd506d6eadb8868
+ sha256sums = SKIP
pkgname = python-traittypes
-
diff --git a/PKGBUILD b/PKGBUILD
index e9cbf4bed545..dfcedee4dcf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-traittypes')
+pkgname='python-traittypes'
_module='traittypes'
pkgver='0.2.1'
-pkgrel=1
+pkgrel=2
pkgdesc="Traitlet types for NumPy, SciPy and friends."
url="https://github.com/jupyter-widgets/traittypes"
depends=('python'
@@ -10,24 +10,24 @@ depends=('python'
'python-numpy'
'python-pandas')
checkdepends=('python-pytest' 'python-xarray')
-makedepends=('python-setuptools')
+makedepends=('git' 'python-setuptools')
license=('BSD')
arch=('any')
-source=("https://github.com/jupyter-widgets/traittypes/archive/${pkgver}.tar.gz")
-sha256sums=('f498c418d04551ea3b21fd97d1f3dcfbc114a672231580bb4e044a188f46efeb')
+source=("git+https://github.com/jupyter-widgets/traittypes.git#commit=af2ebeec9e58b73a12d4cf841bd506d6eadb8868")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
check() {
- cd "${srcdir}/${_module}-${pkgver}"
- python -m unittest
+ cd "${_module}"
+ PYTHONPATH=. pytest
}