summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-03-13 14:34:58 -0500
committerCarlos Aznarán Laos2023-03-13 14:34:58 -0500
commitab8c34fcceb266971220466d56baf20b105d54dd (patch)
tree3903f1d22d2c2b1d100e2577306d9a83924694c1
downloadaur-ab8c34fcceb266971220466d56baf20b105d54dd.tar.gz
Bump version to 2.0.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26037994bce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-trame-matplotlib
+ pkgdesc = Matplotlib widget for trame
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://github.com/Kitware/trame-matplotlib
+ arch = any
+ license = custom:BSD-3-clause
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-trame-client
+ source = trame-matplotlib-2.0.2.tar.gz::https://github.com/Kitware/trame-matplotlib/archive/v2.0.2.tar.gz
+ sha512sums = 2758400fe658697dbb27eb4f2e0cb0acbe7116e912ca69f2d472fdeb129f8f243c51613e2d588f395ccd5cf070297df4546e1323e220ca419d716173540c0de2
+
+pkgname = python-trame-matplotlib
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbb3ce2f5536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=trame-matplotlib
+pkgname=python-${_base}
+pkgdesc="Matplotlib widget for trame"
+pkgver=2.0.2
+pkgrel=1
+arch=(any)
+url="https://github.com/Kitware/${_base}"
+license=('custom:BSD-3-clause')
+depends=(python-trame-client)
+makedepends=(python-setuptools)
+checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('2758400fe658697dbb27eb4f2e0cb0acbe7116e912ca69f2d472fdeb129f8f243c51613e2d588f395ccd5cf070297df4546e1323e220ca419d716173540c0de2')
+
+prepare() {
+ sed -i 's/recursive-include/#recursive-include/' ${_base}-${pkgver}/MANIFEST.in
+ sed -i 's/include/#include/' ${_base}-${pkgver}/MANIFEST.in
+}
+
+build() {
+ cd ${_base}-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm ${pkgdir}${site_packages}/trame/__init__.py
+ rm ${pkgdir}${site_packages}/trame/modules/__init__.py
+ rm ${pkgdir}${site_packages}/trame/widgets/__init__.py
+}