summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-03-14 10:42:15 -0500
committerCarlos Aznarán Laos2023-03-14 10:42:15 -0500
commitdc1349eefe65c6d2b41d5634ad96b414b627e106 (patch)
tree2bd3651f61e3f8839165550b261a644f84bb1d81
parent2d60c67cc65cdebd3412c73f3482c55693d52210 (diff)
downloadaur-dc1349eefe65c6d2b41d5634ad96b414b627e106.tar.gz
Add npm as makedependency
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99279bc7f92a..9b1685692406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = python-trame-matplotlib
license = custom:BSD-3-clause
checkdepends = python-pytest
makedepends = python-setuptools
+ makedepends = npm
depends = python-trame-client
source = trame-matplotlib-2.0.2.tar.gz::https://github.com/Kitware/trame-matplotlib/archive/v2.0.2.tar.gz
sha512sums = 2758400fe658697dbb27eb4f2e0cb0acbe7116e912ca69f2d472fdeb129f8f243c51613e2d588f395ccd5cf070297df4546e1323e220ca419d716173540c0de2
diff --git a/PKGBUILD b/PKGBUILD
index 79bc5411b9eb..7f6f5677367e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=(any)
url="https://github.com/Kitware/${_base}"
license=('custom:BSD-3-clause')
depends=(python-trame-client)
-makedepends=(python-setuptools)
+makedepends=(python-setuptools npm)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('2758400fe658697dbb27eb4f2e0cb0acbe7116e912ca69f2d472fdeb129f8f243c51613e2d588f395ccd5cf070297df4546e1323e220ca419d716173540c0de2')
@@ -18,7 +18,10 @@ prepare() {
}
build() {
- cd ${_base}-${pkgver}
+ cd ${srcdir}/${_base}-${pkgver}/vue-components
+ npm install
+ npm run build
+ cd ${srcdir}/${_base}-${pkgver}
python setup.py build
}