summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-11-09 19:16:40 -0500
committerCarlos Aznarán2023-11-09 19:16:40 -0500
commit11603093e57753713816803451ef61ad8684842d (patch)
treec47211084756125e9f6bd2b46f758879b068d1a5
parentbc397953a3192b2c7a0cc866e4d5199526947754 (diff)
downloadaur-11603093e57753713816803451ef61ad8684842d.tar.gz
Bump version to 2.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a43b62a2af5f..07e74da7a9b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-trame-vtk
pkgdesc = VTK widgets for trame
- pkgver = 2.5.10
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/Kitware/trame-vtk
arch = any
@@ -36,10 +36,10 @@ pkgbase = python-trame-vtk
depends = gl2ps
depends = verdict
depends = qt5-tools
- source = trame-vtk-2.5.10.tar.gz::https://github.com/Kitware/trame-vtk/archive/v2.5.10.tar.gz
+ source = trame-vtk-2.6.0.tar.gz::https://github.com/Kitware/trame-vtk/archive/v2.6.0.tar.gz
source = https://registry.npmjs.org/vue-vtk-js/-/vue-vtk-js-3.1.8.tgz
source = https://raw.githubusercontent.com/Kitware/vtk-js/2d8de2853a1e63c12f9682acb3531083b77c4e3d/examples/OfflineLocalView/OfflineLocalView.html
- sha512sums = f6afb856ad9db9d0473b49b8a482930578d8963cfbae78a8485a0ed1dffecef9a52236697f807049fc0bc34c6559e1478f20bbe36abc6f4af7a234cf123f4a35
+ sha512sums = da1b17a265a07886eb767384f0cf092a8d064a0f768d0e2a6317e3af7a49ed17da4f7c319647aec268800696700f708ab54b7d1ba374d08adb2b11f7706188a1
sha512sums = 59f7a2ddc8b78865679033c228280bb3c2bc3e600ccb3bf194af368fc1933c146508ac9a40438164aedcace5e274e86dd82b5d873c59a04386b6b464a5b57491
sha512sums = 6f09789d876b431370dc55b04ba327092af218d1abea52dd4ec4c9de5b4340cbac2218f438bb231e0cab108f7edcc54d2e15d0c0b262067afb7a515a451414f5
diff --git a/PKGBUILD b/PKGBUILD
index b3a57fdf218b..07b72593d1ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _base=trame-vtk
_npm_base=vue-vtk-js
pkgname=python-${_base}
pkgdesc="VTK widgets for trame"
-pkgver=2.5.10
+pkgver=2.6.0
_npm_pkgver=3.1.8
pkgrel=1
arch=(any)
@@ -17,9 +17,9 @@ checkdepends=(python-pytest-xprocess python-pillow python-pixelmatch python-sele
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
https://registry.npmjs.org/${_npm_base}/-/${_npm_base}-${_npm_pkgver}.tgz
https://raw.githubusercontent.com/Kitware/vtk-js/2d8de2853a1e63c12f9682acb3531083b77c4e3d/examples/OfflineLocalView/OfflineLocalView.html)
-sha512sums=('f6afb856ad9db9d0473b49b8a482930578d8963cfbae78a8485a0ed1dffecef9a52236697f807049fc0bc34c6559e1478f20bbe36abc6f4af7a234cf123f4a35'
- '59f7a2ddc8b78865679033c228280bb3c2bc3e600ccb3bf194af368fc1933c146508ac9a40438164aedcace5e274e86dd82b5d873c59a04386b6b464a5b57491'
- '6f09789d876b431370dc55b04ba327092af218d1abea52dd4ec4c9de5b4340cbac2218f438bb231e0cab108f7edcc54d2e15d0c0b262067afb7a515a451414f5')
+sha512sums=('da1b17a265a07886eb767384f0cf092a8d064a0f768d0e2a6317e3af7a49ed17da4f7c319647aec268800696700f708ab54b7d1ba374d08adb2b11f7706188a1'
+ '59f7a2ddc8b78865679033c228280bb3c2bc3e600ccb3bf194af368fc1933c146508ac9a40438164aedcace5e274e86dd82b5d873c59a04386b6b464a5b57491'
+ '6f09789d876b431370dc55b04ba327092af218d1abea52dd4ec4c9de5b4340cbac2218f438bb231e0cab108f7edcc54d2e15d0c0b262067afb7a515a451414f5')
prepare() {
sed -i 's/^include trame_vtk\/LICENSE/#include trame_vtk\/LICENSE/' ${_base}-${pkgver}/MANIFEST.in
@@ -34,9 +34,9 @@ check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
- test-env/bin/python -m pytest \
- --ignore=tests/test_gc.py \
- -k 'not rendering[examples/validation/PyVistaInt64.py] and not rendering[examples/validation/PyVistaLookupTable.py] and not rendering[examples/validation/VolumeRendering.py]'
+ test-env/bin/python -m pytest
+ # --ignore=tests/test_gc.py \
+ # -k 'not rendering[examples/validation/PyVistaInt64.py] and not rendering[examples/validation/PyVistaLookupTable.py] and not rendering[examples/validation/VolumeRendering.py]'
}
package() {