summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-12-16 08:16:41 +0300
committerDaniel Bershatsky2023-12-16 08:16:46 +0300
commit1716112d91ba53960859fb9eba6c19a3f25a3da0 (patch)
tree67aec2c99d6ce8b1353aa42514917c2b5244d279
parentd698f2eb670219f3f619487e7a785d07e7c0b194 (diff)
downloadaur-1716112d91ba53960859fb9eba6c19a3f25a3da0.tar.gz
Add python-bitsandbytes as optional dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89448819027b..a2c6cf1b88dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-transformers
pkgdesc = State-of-the-art Natural Language Processing for Jax, PyTorch and TensorFlow
pkgver = 4.36.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/huggingface/transformers
arch = any
license = Apache
@@ -20,6 +20,7 @@ pkgbase = python-transformers
depends = python-tokenizers<0.19
depends = python-tqdm
depends = python-yaml
+ optdepends = python-bitsandbytes: 8-bit support for PyTorch
optdepends = python-flax: JAX support
optdepends = python-onnxconverter-common: TensorFlow support
optdepends = python-pytorch: PyTorch support
diff --git a/PKGBUILD b/PKGBUILD
index 3fcac44f3778..b0ecf37454e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-transformers
_pkgname=${pkgname#python-}
pkgver=4.36.1
-pkgrel=1
+pkgrel=2
pkgdesc="State-of-the-art Natural Language Processing for Jax, PyTorch and TensorFlow"
arch=('any')
url='https://github.com/huggingface/transformers'
@@ -25,6 +25,7 @@ depends=(
)
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=(
+ 'python-bitsandbytes: 8-bit support for PyTorch'
'python-flax: JAX support'
'python-onnxconverter-common: TensorFlow support'
'python-pytorch: PyTorch support'