summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-12 21:50:19 -0500
committerLuis Martinez2023-03-12 21:51:01 -0500
commitf00dfd275c2731ae88acf84ff5d43b3fa831d83c (patch)
treeebd346b3fb9e4f6b26979979a5020366582c3589
downloadaur-f00dfd275c2731ae88acf84ff5d43b3fa831d83c.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--CHANGELOG.md31
-rw-r--r--PKGBUILD40
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1c8cdac5a94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-transip
+ pkgdesc = Wrapper for the TransIP API
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/roaldnefs/transip
+ changelog = CHANGELOG.md
+ arch = any
+ license = LGPL3
+ license = GPL3
+ checkdepends = python-pytest
+ checkdepends = python-responses
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-cryptography
+ depends = python-requests
+ source = python-transip-0.6.0.tar.gz::https://files.pythonhosted.org/packages/source/p/python-transip/python-transip-0.6.0.tar.gz
+ sha256sums = d9fd984db4eda4f91b99083c21ad6e00c718c734ad200a53d113fe680c871fe0
+
+pkgname = python-transip
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..81d852581d90
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,31 @@
+# Changelog
+All notable changes in **python-transip** are documented below.
+
+## [Unreleased]
+
+## [0.6.0] (2021-11-01)
+### Added
+- Python 3.10 support ([#49](https://github.com/roaldnefs/python-transip/pull/49)).
+
+## [0.5.0] (2021-02-10)
+### Added
+- The option to replace all existing nameservers of a single domain at once from the `transip.v6.objects.Domain.nameservers` service.
+- The option to list all colocations from the `transip.TransIP.colocations` service ([#24](https://github.com/roaldnefs/python-transip/issues/24)).
+- The option to retrieve a single colocation by name from the `transip.TransIP.colocations` service ([#24](https://github.com/roaldnefs/python-transip/issues/24)).
+- The option to allow the access token to be used from all IP-addresses instead of only the whitelisted ones ([#46](https://github.com/roaldnefs/python-transip/issues/46)).
+
+## [0.4.0] (2021-01-24)
+### Added
+- This `CHANGELOG.md` file to be able to list all notable changes for each version of **python-transip**.
+- The `transip.TransIP.api_test` service to allow calling the test resource to make sure everything is working.
+- The option to list all invoices attached to your TransIP account from the `transip.TransIP.invoices` service.
+- The option to save an invoice as PDF file from `transip.v6.objects.Invoice` object.
+- The option to list all products available in TransIP from the `transip.TransIP.products` service.
+- The option to update a single SSH key from `transip.v6.objects.SshKey` object.
+- The option to update the content of a single DNS record from the `transip.v6.objects.Domain.dns` service, as well as from the `transip.v6.objects.DnsEntry` object.
+- The option to replace all existing DNS records of a single domain at once from the `transip.v6.objects.Domain.dns` service.
+
+[Unreleased]: https://github.com/roaldnefs/python-transip/compare/v0.6.0...HEAD
+[0.6.0]: https://github.com/roaldnefs/python-transip/compare/v0.5.0...v0.6.0
+[0.5.0]: https://github.com/roaldnefs/python-transip/compare/v0.4.0...v0.5.0
+[0.4.0]: https://github.com/roaldnefs/python-transip/compare/v0.3.0...v0.4.0
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2961966fea2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=python-transip
+_pkg="${pkgname#python-}"
+pkgver=0.6.0
+pkgrel=1
+pkgdesc='Wrapper for the TransIP API'
+arch=('any')
+url="https://github.com/roaldnefs/transip"
+license=('LGPL3' 'GPL3')
+depends=('python-cryptography' 'python-requests')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('python-pytest' 'python-responses')
+changelog=CHANGELOG.md
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('d9fd984db4eda4f91b99083c21ad6e00c718c734ad200a53d113fe680c871fe0')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i '/find_packages/s/()/(exclude=["*tests*"])/' setup.py
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ pytest -x tests --disable-warnings
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -dv "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -sv "$_site/${pkgname/-/_}-$pkgver.dist-info/COPYING.LESSER" "$pkgdir/usr/share/licenses/$pkgname/LICENSE-LGPL3"
+ ln -sv "$_site/${pkgname/-/_}-$pkgver.dist-info/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE-GPL3"
+}