summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-02-27 12:27:46 +0100
committerMichel Zou2017-02-27 12:27:46 +0100
commit636d8302f0f16122cd6f9391cfbda95330a6b3e1 (patch)
tree71cfebc89d29175f56410993307c9a81673d9e6d
parentb8e8ce976a37153caeadccc4a49a143f765d2c51 (diff)
downloadaur-636d8302f0f16122cd6f9391cfbda95330a6b3e1.tar.gz
six
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db5adbbc4a5e..c37fc63dd52b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Feb 27 11:16:30 UTC 2017
+# Mon Feb 27 11:27:46 UTC 2017
pkgbase = python-transitions
pkgdesc = A lightweight, object-oriented finite state machine implementation in Python
pkgver = 0.4.3
@@ -9,12 +9,14 @@ pkgbase = python-transitions
license = MIT
makedepends = python-setuptools
makedepends = python2-setuptools
+ makedepends = python-six
+ makedepends = python2-six
source = https://github.com/tyarkoni/transitions/archive/0.4.3.tar.gz
md5sums = 69af441d2ff8e7041f8d3cc6c92ad1d5
pkgname = python-transitions
- depends = python
+ depends = python-six
pkgname = python2-transitions
- depends = python2
+ depends = python2-six
diff --git a/PKGBUILD b/PKGBUILD
index 6d86da16b6ea..96a7bb6b4d2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="A lightweight, object-oriented finite state machine implementation in P
url="http://github.com/tyarkoni/transitions"
arch=(any)
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-six' 'python2-six')
source=("https://github.com/tyarkoni/transitions/archive/${pkgver}.tar.gz")
md5sums=('69af441d2ff8e7041f8d3cc6c92ad1d5')
@@ -25,14 +25,14 @@ build() {
}
package_python-transitions() {
- depends=('python')
+ depends=('python-six')
cd "${srcdir}/transitions-$pkgver"
python setup.py install --root=${pkgdir} --optimize=1
}
package_python2-transitions() {
- depends=('python2')
+ depends=('python2-six')
cd "${srcdir}/transitions-$pkgver"
python2 setup.py install --root=${pkgdir} --optimize=1