summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-02-27 12:16:30 +0100
committerMichel Zou2017-02-27 12:16:30 +0100
commitb8e8ce976a37153caeadccc4a49a143f765d2c51 (patch)
treed84feda874af788085fe25451345656966da127e
downloadaur-b8e8ce976a37153caeadccc4a49a143f765d2c51.tar.gz
0.4.3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db5adbbc4a5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Feb 27 11:16:30 UTC 2017
+pkgbase = python-transitions
+ pkgdesc = A lightweight, object-oriented finite state machine implementation in Python
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = http://github.com/tyarkoni/transitions
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://github.com/tyarkoni/transitions/archive/0.4.3.tar.gz
+ md5sums = 69af441d2ff8e7041f8d3cc6c92ad1d5
+
+pkgname = python-transitions
+ depends = python
+
+pkgname = python2-transitions
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d86da16b6ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgbase=python-transitions
+pkgname=('python-transitions' 'python2-transitions')
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="A lightweight, object-oriented finite state machine implementation in Python"
+url="http://github.com/tyarkoni/transitions"
+arch=(any)
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/tyarkoni/transitions/archive/${pkgver}.tar.gz")
+md5sums=('69af441d2ff8e7041f8d3cc6c92ad1d5')
+
+prepare() {
+ cd "${srcdir}"/transitions-$pkgver
+}
+
+build() {
+ cp -r "${srcdir}"/transitions-$pkgver "${srcdir}"/transitions-$pkgver-py2
+
+ cd "${srcdir}"/transitions-$pkgver
+ python setup.py build
+
+ cd "${srcdir}"/transitions-$pkgver-py2
+ python2 setup.py build
+}
+
+package_python-transitions() {
+ depends=('python')
+
+ cd "${srcdir}/transitions-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+package_python2-transitions() {
+ depends=('python2')
+
+ cd "${srcdir}/transitions-$pkgver"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+