summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvantu5z2021-03-04 11:26:45 +0300
committervantu5z2021-03-04 11:26:45 +0300
commitb772336fdb8a741a4f620fb42781fe346eece0a3 (patch)
tree7f1c47a50a5ff3ea38248eadc585b34921ddad5b
downloadaur-b772336fdb8a741a4f620fb42781fe346eece0a3.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a853c525d20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-translate
+ pkgdesc = Translate is a simple but powerful translation tool written in python with with support for multiple translation providers.
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://github.com/terryyin/translate-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = python-translate::https://github.com/terryyin/translate-python/archive/3.5.0.tar.gz
+ sha256sums = fb3bd2153d02861607c946a0d24141e6f7d7f111deadd3dc42f0737778423224
+
+pkgname = python-translate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a2c2e600bd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: vantu5z <vantu5z@mail.ru>
+
+pkgname=python-translate
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="Translate is a simple but powerful translation tool written in python with with support for multiple translation providers."
+url="https://github.com/terryyin/translate-python"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=(${pkgname}::"https://github.com/terryyin/translate-python/archive/$pkgver.tar.gz")
+sha256sums=('fb3bd2153d02861607c946a0d24141e6f7d7f111deadd3dc42f0737778423224')
+
+build() {
+ cd "${srcdir}/translate-python-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/translate-python-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}