summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvantu5z2022-07-25 09:32:13 +0300
committervantu5z2022-07-25 09:32:13 +0300
commitc2d09e9e9d89eeb822b60df89bbd47c92084783c (patch)
tree3ad0971bde7b1c51d1041cd29575d8d3a1ebee70
parentf97dfdc0e9de3da56ec8fee1baf99e6c7d759e70 (diff)
downloadaur-c2d09e9e9d89eeb822b60df89bbd47c92084783c.tar.gz
add dependency -> python-libretranslate
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f343dcfd65c7..aaab24e3fb59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-translate
pkgdesc = Translate is a simple but powerful translation tool written in python with support for multiple translation providers.
pkgver = 3.6.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/terryyin/translate-python
arch = any
license = MIT
@@ -10,6 +10,7 @@ pkgbase = python-translate
makedepends = python-wheel
makedepends = python-pytest-runner
depends = python
+ depends = python-libretranslate
source = python-translate::https://github.com/terryyin/translate-python/archive/refs/tags/3.6.1.tar.gz
sha256sums = 28ddafe090847031a46f626fd06a2adaff067ff9f7c15234e05b196c9393f7f1
diff --git a/PKGBUILD b/PKGBUILD
index bc25d1b1b566..d50d2df4b5b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname=python-translate
pkgver=3.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="Translate is a simple but powerful translation tool written in python with support for multiple translation providers."
url="https://github.com/terryyin/translate-python"
-depends=('python')
+depends=('python' 'python-libretranslate')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-pytest-runner')
license=('MIT')
arch=('any')
source=(${pkgname}::"https://github.com/terryyin/translate-python/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('28ddafe090847031a46f626fd06a2adaff067ff9f7c15234e05b196c9393f7f1')
+
build() {
cd "${srcdir}/translate-python-${pkgver}"
python -m build --wheel --no-isolation