summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2022-12-09 04:45:01 +0800
committerWu Zhenyu2022-12-09 04:45:01 +0800
commit50ccd25fa741d59701cfb027cc02ea0f52000fc7 (patch)
treee80e434a09f67e79d7e4e9936c9d155d478c12d5
parente1963fe25c44caaeaa560b0cf4bffff2b9c36936 (diff)
downloadaur-50ccd25fa741d59701cfb027cc02ea0f52000fc7.tar.gz
:art: Format code
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75c8deb5e299..637ce746d570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = python-translate-shell
- pkgdesc = Translate text by google, bing, haici, etc at same time from CLI, GUI, REPL, python, shell and vim.
+ pkgdesc = Translate text by google, bing, youdaozhiyun, haici, stardict, etc at same time from CLI, GUI (GNU/Linux, Android, macOS and Windows), REPL, python, shell and vim.
pkgver = 0.0.6
pkgrel = 1
url = https://github.com/Freed-Wu/translate-shell
@@ -15,8 +15,8 @@ pkgbase = python-translate-shell
optdepends = python-py-notifier: GUI notification
optdepends = xsel: clipboard support
optdepends = xclip: clipboard support
- optdepends = festival: speaker support
optdepends = espeak-ng: speaker support
+ optdepends = festival: speaker support
conflicts = translate-shell
source = https://files.pythonhosted.org/packages/py3/t/translate-shell/translate_shell-0.0.6-py3-none-any.whl
source = https://raw.githubusercontent.com/Freed-Wu/translate-shell/main/assets/desktop/translate-shell.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 5226432aa79b..04d57421679b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,17 +28,18 @@ optdepends=(
'espeak-ng: speaker support'
'festival: speaker support'
)
-conflicts=(translate-shell)
+conflicts=("$_pkgname")
license=(GPLv3)
_py=py3
+_bin=trans
source=(
"https://files.pythonhosted.org/packages/$_py/${_pkgname:0:1}/$_pkgname/${_pkgname//-/_}-$pkgver-$_py-none-any.whl"
- "https://raw.githubusercontent.com/$_repo/main/assets/desktop/translate-shell.desktop"
+ "https://raw.githubusercontent.com/$_repo/main/assets/desktop/$_pkgname.desktop"
"https://raw.githubusercontent.com/$_repo/main/LICENSE"
- "https://github.com/Freed-Wu/translate-shell/releases/download/0.0.6/trans.1.gz"
- "https://github.com/Freed-Wu/translate-shell/releases/download/0.0.6/trans"
- "https://github.com/Freed-Wu/translate-shell/releases/download/0.0.6/_trans"
- "https://github.com/Freed-Wu/translate-shell/releases/download/0.0.6/trans.csh"
+ "$url/releases/download/$pkgver/$_bin.1.gz"
+ "$url/releases/download/$pkgver/$_bin"
+ "$url/releases/download/$pkgver/_$_bin"
+ "$url/releases/download/$pkgver/$_bin.csh"
)
sha256sums=(
'72095a6dfcb9df4d0afe193c4c0cfe6f975161e27ffe333fac7af7b4cdcb43b3'
@@ -55,10 +56,10 @@ package() {
python -m installer --destdir="$pkgdir" ./*.whl
install -Dm644 "$pkgdir$(python -c'import sys; print(sys.path[-1])')/${_pkgname//-/_}/assets/images/icon.png" -t "$pkgdir/usr/share/$_pkgname/images"
- install -Dm644 translate-shell.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 "$_pkgname.desktop" -t "$pkgdir/usr/share/applications"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- install -Dm644 trans.1.gz -t "$pkgdir/usr/share/man/man1"
- install -Dm644 trans -t "$pkgdir/usr/share/bash-completion/completions"
- install -Dm644 _trans -t "$pkgdir/usr/share/zsh/site-functions"
- install -Dm644 trans.csh -t "$pkgdir/etc/profile.d"
+ install -Dm644 "$_bin.1.gz" -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 "$_bin" -t "$pkgdir/usr/share/bash-completion/completions"
+ install -Dm644 "_$_bin" -t "$pkgdir/usr/share/zsh/site-functions"
+ install -Dm644 "$_bin.csh" -t "$pkgdir/etc/profile.d"
}