summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-03-21 15:35:12 +0800
committerWu Zhenyu2023-03-21 15:35:12 +0800
commit57a030618316d1c936d177184a97b4fd348d21ed (patch)
tree4d8588edb270ba8833bfe361bb3484092c5d978f
parent7457108abefc71cc1d072ce52dcadc5fcfea8d8d (diff)
downloadaur-57a030618316d1c936d177184a97b4fd348d21ed.tar.gz
:alien: update to 0.0.18;
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD11
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0ee5d3323aa..a899f3f55023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-translate-shell
pkgdesc = Translate text by google, bing, youdaozhiyun, haici, stardict, etc at same time from CLI, GUI (GNU/Linux, Android, macOS and Windows), REPL, python, shell and vim.
- pkgver = 0.0.17
+ pkgver = 0.0.18
pkgrel = 1
url = https://github.com/Freed-Wu/translate-shell
arch = any
license = GPLv3
makedepends = python-installer
- optdepends = python-colorama: color
+ optdepends = python-repl-python-wakatime: wakatime support
+ optdepends = python-colorama: color support
optdepends = python-rich: better logger
optdepends = python-yaml: output yaml format
optdepends = python-keyring: store APP secrets securely
@@ -18,19 +19,19 @@ pkgbase = python-translate-shell
optdepends = espeak-ng: speaker support
optdepends = festival: speaker support
conflicts = translate-shell
- source = https://files.pythonhosted.org/packages/py3/t/translate-shell/translate_shell-0.0.17-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/t/translate-shell/translate_shell-0.0.18-py3-none-any.whl
source = https://raw.githubusercontent.com/Freed-Wu/translate-shell/main/assets/desktop/translate-shell.desktop
source = https://raw.githubusercontent.com/Freed-Wu/translate-shell/main/LICENSE
- source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.17/trans.1.gz
- source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.17/trans
- source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.17/_trans
- source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.17/trans.csh
- sha256sums = 0e3f7ffa0939f876c8d11a82075197cb416b7f9a4965bf8d9fe803a5c4444593
+ source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.18/trans.1.gz
+ source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.18/trans
+ source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.18/_trans
+ source = https://github.com/Freed-Wu/translate-shell/releases/download/0.0.18/trans.csh
+ sha256sums = 5821b9842a7d35a6732da3420278bcab47e32de24032f2f8c8757e3ea80184f5
sha256sums = 11f0c6092d30867b09ea9f2f1562169ce8cc0c4476181dd62dbad63b16752972
sha256sums = 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986
- sha256sums = 6b7a53d253a0aec48cbf2a134ec382383d545dfe35c19a2d03e9d11cc659c9ee
+ sha256sums = 5b6958399a7e222002a6317282802cf9b7d544eee17815894671d0395bb2f3c1
sha256sums = 3a111e40861566af47f0c440c8d5989f9fd5971bf4d57789d8c2e0cce81cf2dc
sha256sums = 6a437deae1674c41648bfc8f7ab0272a564213d43fa2e29a664b9e3256ab8214
- sha256sums = bc69ce45658427a760a19a03690bf860f55a70a443020153e6b2bf565bedf48a
+ sha256sums = 85ca52dfe53aa61fdf9ed935dd238c38789d6e69471eefeab1315bf59492b3e9
pkgname = python-translate-shell
diff --git a/PKGBUILD b/PKGBUILD
index bc23cd9e3d74..a7829832f579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# $ updaurpkg --apply
_repo=Freed-Wu/translate-shell
_source_type=pypi-releases
-_upstreamver='0.0.17'
+_upstreamver='0.0.18'
_pkgname=$(tr A-Z a-z <<<${_repo##*/})
_pypi_package=$_pkgname
@@ -16,7 +16,8 @@ arch=(any)
url=https://github.com/$_repo
makedepends=(python-installer)
optdepends=(
- 'python-colorama: color'
+ 'python-repl-python-wakatime: wakatime support'
+ 'python-colorama: color support'
'python-rich: better logger'
'python-yaml: output yaml format'
'python-keyring: store APP secrets securely'
@@ -41,13 +42,13 @@ source=(
"$url/releases/download/$pkgver/_$_bin"
"$url/releases/download/$pkgver/$_bin.csh"
)
-sha256sums=('0e3f7ffa0939f876c8d11a82075197cb416b7f9a4965bf8d9fe803a5c4444593'
+sha256sums=('5821b9842a7d35a6732da3420278bcab47e32de24032f2f8c8757e3ea80184f5'
'11f0c6092d30867b09ea9f2f1562169ce8cc0c4476181dd62dbad63b16752972'
'3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986'
- '6b7a53d253a0aec48cbf2a134ec382383d545dfe35c19a2d03e9d11cc659c9ee'
+ '5b6958399a7e222002a6317282802cf9b7d544eee17815894671d0395bb2f3c1'
'3a111e40861566af47f0c440c8d5989f9fd5971bf4d57789d8c2e0cce81cf2dc'
'6a437deae1674c41648bfc8f7ab0272a564213d43fa2e29a664b9e3256ab8214'
- 'bc69ce45658427a760a19a03690bf860f55a70a443020153e6b2bf565bedf48a')
+ '85ca52dfe53aa61fdf9ed935dd238c38789d6e69471eefeab1315bf59492b3e9')
package() {
cd "$srcdir" || return 1