summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2022-12-06 04:55:20 +0800
committerWu Zhenyu2022-12-06 05:03:17 +0800
commitf3dae1f71834a27f5a678e3995d94fdda34a0b0e (patch)
tree8b49e1a4fe00c02164dd92a4c48a8b421cd704b7
parent2d09d937c39a6f99dd42ad8016eb5f8acfaae423 (diff)
downloadaur-f3dae1f71834a27f5a678e3995d94fdda34a0b0e.tar.gz
:alien: Update to 0.0.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bc311821b5b..b3eeb2de3873 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-translate-shell
- pkgdesc = Translate text by many different translators.
- pkgver = 0.0.3
+ pkgdesc = Translate text by google, bing, haici, etc at same time from CLI, GUI, REPL, python, shell and vim.
+ pkgver = 0.0.4
pkgrel = 1
url = https://github.com/Freed-Wu/translate-shell
arch = any
@@ -14,8 +14,11 @@ pkgbase = python-translate-shell
optdepends = python-keyring: store APP secrets securely
optdepends = python-langdetect: detect language automatically for offline dictionary
optdepends = python-pystardict: offline dictionary
+ optdepends = python-py-notifier: GUI notification
conflicts = translate-shell
- source = https://files.pythonhosted.org/packages/py3/t/translate-shell/translate_shell-0.0.3-py3-none-any.whl
- sha256sums = 9627b56aa5723c5904440e9f55bad546683d1e25c64cf9ff1fb5f9aa0a9bd0b6
+ source = https://files.pythonhosted.org/packages/py3/t/translate-shell/translate_shell-0.0.4-py3-none-any.whl
+ source = https://raw.githubusercontent.com/Freed-Wu/translate-shell/main/assets/desktop/translate-shell.desktop
+ sha256sums = 0190cbadceaa6786c504efe0f1d0af329d5df71113e4a43a8ee9b7e74d2dc2f1
+ sha256sums = 45fdff8b6ddc514190abdb61354f0583b1a490466bfb65cceec4d6ea12a776f6
pkgname = python-translate-shell
diff --git a/PKGBUILD b/PKGBUILD
index fb402cfa449b..f1963dd655e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
# https://aur.archlinux.org/packages/updaurpkg-git
# $ updaurpkg --apply
_repo=Freed-Wu/translate-shell
-_source_type=github-tags
-_upstreamver='0.0.3'
+_source_type=pypi-releases
+_upstreamver='0.0.4'
_pkgname=$(tr A-Z a-z <<<${_repo##*/})
+_pypi_package=$_pkgname
pkgname=python-$_pkgname
pkgver=${_upstreamver##v}
pkgrel=1
-pkgdesc="Translate text by many different translators."
+pkgdesc="Translate text by google, bing, haici, etc at same time from CLI, GUI, REPL, python, shell and vim."
arch=(any)
url=https://github.com/$_repo
makedepends=(python-installer python-shtab help2man)
@@ -21,12 +22,17 @@ optdepends=(
'python-keyring: store APP secrets securely'
'python-langdetect: detect language automatically for offline dictionary'
'python-pystardict: offline dictionary'
+ 'python-py-notifier: GUI notification'
)
conflicts=(translate-shell)
license=(GPLv3)
_py=py3
-source=("https://files.pythonhosted.org/packages/$_py/${_pkgname:0:1}/$_pkgname/${_pkgname//-/_}-$pkgver-$_py-none-any.whl")
-sha256sums=('9627b56aa5723c5904440e9f55bad546683d1e25c64cf9ff1fb5f9aa0a9bd0b6')
+source=(
+ "https://files.pythonhosted.org/packages/$_py/${_pkgname:0:1}/$_pkgname/${_pkgname//-/_}-$pkgver-$_py-none-any.whl"
+ "https://raw.githubusercontent.com/$_repo/main/assets/desktop/translate-shell.desktop"
+)
+sha256sums=('0190cbadceaa6786c504efe0f1d0af329d5df71113e4a43a8ee9b7e74d2dc2f1'
+ '45fdff8b6ddc514190abdb61354f0583b1a490466bfb65cceec4d6ea12a776f6')
package() {
cd "$srcdir" || return 1
@@ -35,13 +41,16 @@ package() {
local bin
bin=trans
help2man "$pkgdir/usr/bin/$bin" | gzip >"$bin.1.gz"
- install -D "$bin.1.gz" -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 "$bin.1.gz" -t "$pkgdir/usr/share/man/man1"
PYTHONPATH="$(ls -d "$pkgdir"/usr/lib/python*/site-packages)"
export PYTHONPATH
"$pkgdir/usr/bin/$bin" --print-completion bash >"$bin.bash"
"$pkgdir/usr/bin/$bin" --print-completion zsh >"_$bin"
"$pkgdir/usr/bin/$bin" --print-completion tcsh >"$bin.csh"
- install -D "$bin.bash" "$pkgdir/usr/share/bash-completion/completions/$bin"
- install -D "_$bin" -t "$pkgdir/usr/share/zsh/site-functions"
- install -D "$bin.csh" -t "$pkgdir/etc/profile.d"
+ install -Dm644 "$bin.bash" "$pkgdir/usr/share/bash-completion/completions/$bin"
+ install -Dm644 "_$bin" -t "$pkgdir/usr/share/zsh/site-functions"
+ install -Dm644 "$bin.csh" -t "$pkgdir/etc/profile.d"
+
+ install -Dm644 "$PYTHONPATH/translate_shell/assets/images/icon.png" -t "$pkgdir/usr/share/translate-shell/images"
+ install -Dm644 translate-shell.desktop -t "$pkgdir/usr/share/applications"
}