summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-18 15:22:42 -0500
committerCarlos Aznarán Laos2023-05-18 15:22:42 -0500
commit16163784127cc49a5e5d4790be60d845eb423701 (patch)
tree0632ecbd2fc951597e9412cbe805aa0a1d91f843
parentba8d603991392973a59a550b25e60e423c9e8ffa (diff)
downloadaur-16163784127cc49a5e5d4790be60d845eb423701.tar.gz
Bump version to 4.3.3
-rw-r--r--.SRCINFO18
-rw-r--r--CHANGELOG.rst48
-rw-r--r--PKGBUILD55
3 files changed, 39 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fbb910bacdb..a3d11c629e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = python-treecorr
- pkgdesc = Library that efficiently computes 2-point and 3-point correlation functions
- pkgver = 4.3.0
+ pkgdesc = Module for computing 2-point correlation functions
+ pkgver = 4.3.3
pkgrel = 1
- url = https://github.com/rmjarvis/treecorr
- changelog = CHANGELOG.rst
+ url = https://github.com/rmjarvis/TreeCorr
arch = x86_64
license = BSD
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
- makedepends = python-sphinx
makedepends = python-wheel
- depends = python-cffi
- depends = python-coord
+ makedepends = python-sphinx
depends = python-numpy
+ depends = python-cffi
depends = python-yaml
+ depends = python-coord
optdepends = python-fitsio: reads FITS catalogs or writes to FITS output files
optdepends = python-pandas: speeds up reading from ASCII catalogs
optdepends = python-h5py: reads HDF5 catalogs
- source = python-treecorr-4.3.0.tar.gz::https://github.com/rmjarvis/treecorr/archive/v4.3.0.tar.gz
- sha256sums = 7ede747f29079f7bba083511519164446ee8b56313e33a1ed1dde674c10fc56f
+ source = python-treecorr-4.3.3.tar.gz::https://github.com/rmjarvis/TreeCorr/archive/v4.3.3.tar.gz
+ sha512sums = 9474e1539b13b5e4e588714b5a099542e35895d83d08912c335586120777e2edebbe44e3f56a56e376065bd6c6e4b274c6d6f8a9ef09440d910f28ff31601703
pkgname = python-treecorr
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
deleted file mode 100644
index 3e50393bbf6c..000000000000
--- a/CHANGELOG.rst
+++ /dev/null
@@ -1,48 +0,0 @@
-Changes from version 4.2 to 4.3
-===============================
-
-See the listing below for the complete list of new features and changes.
-`Relevant PRs and Issues,
-<https://github.com/rmjarvis/TreeCorr/issues?q=milestone%3A%22Version+4.3%22+is%3Aclosed>`_
-whose issue numbers are listed below for the relevant items.
-
-System Support Changes
-----------------------
-
-- Starting with this version, TreeCorr no longer supports Python 2.7 or 3.6.
- We currently support Python versions 3.7, 3,8, 3.9, 3.10.
-
-- We now support Windows machines, which we hadn't before this. Code is now regularly
- tested on ubuntu, macos and windows. (#136, #143)
-
-
-API Changes
------------
-
-- Many function parameters are now keyword-only. The old syntax allowing these parameters
- to be positional still works, but is deprecated. (#129)
-
-
-Performance improvements
-------------------------
-
-- Added ability to compute patch-based covariance matrices using MPI. (#138, #139)
-
-
-New features
-------------
-
-- Add `BinnedCorr2.build_cov_design_matrix` and `build_multi_cov_design_matrix` functions (#132)
-- Added ability to write out the full set of pair-wise results in the write commands, and to
- read them back in. This allows correlation objects to still be able to correctly calculate
- the various patch-based covariance matrix estimates after round-tripping through a file.
- To use this feature, use ``corr.write(..., write_patch_results=True)``. (#141)
-- Allow None as a configuration parameter to be equivalent to not specifying a parameter.
- E.g. ``bin_size=0.1, min_sep=1., max_sep=100., nbins=None`` is allowed now. (#142)
-
-
-Bug fixes
----------
-
-- Fixed a bug where correlation objects using bin_type=TwoD could not be correctly read back
- in after being written to a file. (#141)
diff --git a/PKGBUILD b/PKGBUILD
index 611fcc60d4b9..3f06113fa832 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
# Contributor: M. Jarvis
-
-pkgname=python-treecorr
-_pkg=TreeCorr
-pkgver=4.3.0
+_base=TreeCorr
+pkgname=python-${_base,,}
+pkgver=4.3.3
pkgrel=1
-pkgdesc="Library that efficiently computes 2-point and 3-point correlation functions"
+pkgdesc="Module for computing 2-point correlation functions"
arch=('x86_64')
-url="https://github.com/rmjarvis/treecorr"
+url="https://github.com/rmjarvis/${_base}"
license=('BSD')
-depends=('python-cffi' 'python-coord' 'python-numpy' 'python-yaml')
-optdepends=(
- 'python-fitsio: reads FITS catalogs or writes to FITS output files'
- 'python-pandas: speeds up reading from ASCII catalogs'
- 'python-h5py: reads HDF5 catalogs')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-sphinx' 'python-wheel')
-# checkdepends=('python-fitsio' 'python-pandas' 'python-hdpy' 'python-scipy')
-changelog=CHANGELOG.rst
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('7ede747f29079f7bba083511519164446ee8b56313e33a1ed1dde674c10fc56f')
+depends=(python-numpy python-cffi python-yaml python-coord)
+makedepends=(python-build python-installer python-setuptools python-wheel python-sphinx)
+optdepends=('python-fitsio: reads FITS catalogs or writes to FITS output files'
+ 'python-pandas: speeds up reading from ASCII catalogs'
+ 'python-h5py: reads HDF5 catalogs')
+checkdepends=(python-pytest) # python-fitsio python-pandas python-hdpy python-scipy
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('9474e1539b13b5e4e588714b5a099542e35895d83d08912c335586120777e2edebbe44e3f56a56e376065bd6c6e4b274c6d6f8a9ef09440d910f28ff31601703')
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
- local _ver="$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')"
- PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$_ver" make -C docs man
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+ local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
+ PYTHONPATH="${PWD}/build/lib.linux-$CARCH-cpython-${_pyversion}" make -C docs man
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest tests
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 TreeCorr_LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 docs/_build/man/TreeCorr.1 -t "$pkgdir/usr/share/man/man1/"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 ${_base}_LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 docs/_build/man/${_base}.1 -t "${pkgdir}/usr/share/man/man1/"
}