summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-31 01:13:43 -0200
committerandalenavals2017-10-31 01:13:43 -0200
commit8be7d6e15feebb4758ab978e8ae957cf718be947 (patch)
treeffbbe86f23e5a1b362737744e149efe5168756ac
downloadaur-8be7d6e15feebb4758ab978e8ae957cf718be947.tar.gz
This pkgbuild is highly dependent of the version of python-cffio, so any update in version will break the pkg build. By the moment this a realese for testing other packages that depend on this
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b5137e7bcee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-treecorr
+ pkgdesc = A package for efficiently computing 2-point and 3-point correlation functions
+ pkgver = 3.3.7
+ pkgrel = 1
+ url = https://pypi.python.org/packages/5a/59/466fca95804e60a4ad0cf34de70e92fd57e6a711d09fbf1f0f8d00f833de/TreeCorr-3.3.7.tar.gz#md5=54bdf201d7e8a52b5fa9ea5e1ff1d101
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = python-future
+ depends = python-aspy-yaml
+ depends = python-fitsio
+ depends = python-cffi
+ source = https://pypi.python.org/packages/5a/59/466fca95804e60a4ad0cf34de70e92fd57e6a711d09fbf1f0f8d00f833de/TreeCorr-3.3.7.tar.gz#md5=54bdf201d7e8a52b5fa9ea5e1ff1d101
+ md5sums = 54bdf201d7e8a52b5fa9ea5e1ff1d101
+
+pkgname = python-treecorr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee39e467cdf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+pkgname=python-treecorr
+pkgver=3.3.7
+pkgrel=1
+#epoch=
+
+pkgdesc="A package for efficiently computing 2-point and 3-point correlation functions "
+
+
+arch=('any')
+url="https://pypi.python.org/packages/5a/59/466fca95804e60a4ad0cf34de70e92fd57e6a711d09fbf1f0f8d00f833de/TreeCorr-3.3.7.tar.gz#md5=54bdf201d7e8a52b5fa9ea5e1ff1d101"
+license=('BSD')
+groups=()
+depends=('python' 'python-numpy' 'python-future' 'python-aspy-yaml' 'python-fitsio' 'python-cffi')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("${url}")
+#noextract=()
+md5sums=('54bdf201d7e8a52b5fa9ea5e1ff1d101')
+#validpgpkeys=()
+
+
+build() {
+ sudo cp /usr/lib/libffi-3.2.1/include/ffi*.h /usr/include
+ cd "$src"
+ cd "TreeCorr-$pkgver"
+ python setup.py build
+}
+
+
+package() {
+ cd "$src"
+ cd "TreeCorr-$pkgver"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+
+}