summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-21 19:35:37 -0500
committerCarlos Aznarán Laos2023-05-21 19:35:37 -0500
commitaffcc26b184f0572436f8a17bac6497512ee7559 (patch)
treeddfa986b2b62750f51a595dcd86f6aeb59db451d
parent0bd61021058c40b4894b2e915ad9ba5d16a976ed (diff)
downloadaur-affcc26b184f0572436f8a17bac6497512ee7559.tar.gz
Comment check()
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f13e9a215fa2..874946bb217a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=python-${_base,,}
pkgver=4.3.3
pkgrel=1
pkgdesc="Module for computing 2-point correlation functions"
-arch=('x86_64')
+arch=(x86_64)
url="https://github.com/rmjarvis/${_base}"
license=('BSD')
depends=(python-numpy python-cffi python-yaml python-coord)
@@ -15,7 +15,7 @@ makedepends=(python-build python-installer python-setuptools python-wheel)
optdepends=('python-fitsio: reads FITS catalogs or writes to FITS output files'
'python-pandas: speeds up reading from ASCII catalogs'
'python-h5py: reads HDF5 catalogs')
-# checkdepends=(python-pytest) # python-fitsio python-pandas python-hdpy python-scipy
+# checkdepends=(python-pytest python-pandas python-fitsio python-mockmpi) # python-scipy python-hdpy
source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('9474e1539b13b5e4e588714b5a099542e35895d83d08912c335586120777e2edebbe44e3f56a56e376065bd6c6e4b274c6d6f8a9ef09440d910f28ff31601703')
@@ -28,6 +28,8 @@ build() {
# cd ${_base}-${pkgver}
# python -m venv --system-site-packages test-env
# test-env/bin/python -m installer dist/*.whl
+# local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}{sys.version_info.minor}')")
+# mv build/lib.linux-$CARCH-cpython-${_pyversion}/${_base,,}/_${_base,,}.cpython-${_pyversion}-$CARCH-linux-gnu.so ${_base,,}/_${_base,,}.so
# test-env/bin/python -m pytest tests
# }