summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-05-11 22:53:00 -0500
committerCarlos Aznarán Laos2022-05-11 22:53:00 -0500
commit6269399cf118db93efd07fbfb66d251e3991f6fc (patch)
treedd8a9ad4f0e1b54d2e0228e972b28bb295de04e7
downloadaur-6269399cf118db93efd07fbfb66d251e3991f6fc.tar.gz
Bump version to 0.3.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8cf7d032002
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-treestamps
+ pkgdesc = Create timestamp records for recursive operations on directory trees
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/ajslater/treestamps
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-ruamel-yaml
+ depends = python-termcolor
+ source = https://pypi.org/packages/source/t/treestamps/treestamps-0.3.1.tar.gz
+ sha512sums = 9405ba6a7d77713018494d3095bdd4b82a0fa0fba5ac916a821ae75b4b3292728579ab0dee1fe6d8a8cd24a9bc5417b013ed0d9e20188fa92fe8a72d13dbd933
+
+pkgname = python-treestamps
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61cf3007664f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=treestamps
+pkgname=python-${_base}
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Create timestamp records for recursive operations on directory trees"
+url="https://github.com/ajslater/${_base}"
+depends=(python-ruamel-yaml python-termcolor)
+makedepends=(python-setuptools)
+license=(GPL3)
+arch=(any)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('9405ba6a7d77713018494d3095bdd4b82a0fa0fba5ac916a821ae75b4b3292728579ab0dee1fe6d8a8cd24a9bc5417b013ed0d9e20188fa92fe8a72d13dbd933')
+
+build() {
+ cd ${_base}-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ PYTHONPATH="${PWD}/build/lib:${PYTHONPATH}" python tests/unit/*.py
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+}