summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryate2021-08-27 11:16:38 -0400
committeryate2021-08-27 11:16:38 -0400
commit20efab400d5befd78ffafdc617a1173f55d0ee9a (patch)
treeb2cdcb1d0bfb4147901d46ba9c74372e9659fa9e
parentcf60117b305bd2ac14784323fa5b0feb4e625971 (diff)
downloadaur-20efab400d5befd78ffafdc617a1173f55d0ee9a.tar.gz
0.12.3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fec2f43ec071..72a380624af0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-trezor
pkgdesc = Python 3 library for communicating with the TREZOR Bitcoin hardware wallet
- pkgver = 0.12.2
- pkgrel = 3
+ pkgver = 0.12.3
+ pkgrel = 1
url = https://github.com/trezor/trezor-firmware/tree/master/python
arch = any
license = LGPL3
@@ -9,7 +9,6 @@ pkgbase = python-trezor
depends = protobuf
depends = python
depends = python-ecdsa
- depends = python-hidapi
depends = python-mnemonic
depends = python-click
depends = python-pyblake2
@@ -19,12 +18,12 @@ pkgbase = python-trezor
depends = python-libusb1
depends = python-typing_extensions
depends = python-attrs
+ optdepends = python-hidapi: Firmware-less Trezor One setup
provides = python-trezor
provides = trezorctl
conflicts = trezorctl
options = !emptydirs
- source = https://files.pythonhosted.org/packages/40/bb/e5aff94fb22fcce0b57dd773b5fd1e8b7bdd16c4bc982755984b9a09bb7d/trezor-0.12.2.tar.gz
- sha256sums = 5bd226b829e5f6ad6c7263f5303f58b54e07b0f21263c4b8ba57981881071264
+ source = https://files.pythonhosted.org/packages/00/49/c9b3a0beaafb85a4f123e5fbd04c15c20d89e86e397e95a0e5024a179a3b/trezor-0.12.3.tar.gz
+ sha256sums = 02c39c333435b8f6dc62cc79bb5bf35fc7f0eb144a1a748be3b7c065ee3e85ae
pkgname = python-trezor
-
diff --git a/PKGBUILD b/PKGBUILD
index a5f823694d16..8ea5cd74e7cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python-trezor
-pkgver=0.12.2
-pkgrel=3
+pkgver=0.12.3
+pkgrel=1
pkgdesc='Python 3 library for communicating with the TREZOR Bitcoin hardware wallet'
arch=('any')
+makedepends=('python-setuptools')
depends=('protobuf'
'python'
'python-ecdsa'
- 'python-hidapi'
'python-mnemonic'
'python-click'
'python-pyblake2'
@@ -20,12 +20,12 @@ depends=('protobuf'
'python-libusb1'
'python-typing_extensions'
'python-attrs')
-makedepends=('python-setuptools')
+optdepends=('python-hidapi: Firmware-less Trezor One setup')
url='https://github.com/trezor/trezor-firmware/tree/master/python'
license=('LGPL3')
options=(!emptydirs)
-source=('https://files.pythonhosted.org/packages/40/bb/e5aff94fb22fcce0b57dd773b5fd1e8b7bdd16c4bc982755984b9a09bb7d/trezor-0.12.2.tar.gz')
-sha256sums=('5bd226b829e5f6ad6c7263f5303f58b54e07b0f21263c4b8ba57981881071264')
+source=('https://files.pythonhosted.org/packages/00/49/c9b3a0beaafb85a4f123e5fbd04c15c20d89e86e397e95a0e5024a179a3b/trezor-0.12.3.tar.gz')
+sha256sums=('02c39c333435b8f6dc62cc79bb5bf35fc7f0eb144a1a748be3b7c065ee3e85ae')
provides=('python-trezor' 'trezorctl')
conflicts=('trezorctl')