summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin 'golodhrim' Scholz2019-07-14 17:36:36 +0200
committerMartin 'golodhrim' Scholz2019-07-14 17:36:36 +0200
commit62e8e33ad2d1057f9adfda3981b0dd5e4c18dbde (patch)
treef61bae7fa5398280048f64947b24b3af1f7b8c3a
downloadaur-62e8e33ad2d1057f9adfda3981b0dd5e4c18dbde.tar.gz
adding module python-trytond_company for trytond
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad80b858b36d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-trytond_company
+ pkgdesc = Tryton module with companies and employees
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = http://www.tryton.org/
+ arch = any
+ license = GPL3
+ makedepends = python-distribute
+ depends = python>=3.5
+ source = https://files.pythonhosted.org/packages/source/t/trytond_company/trytond_company-5.2.0.tar.gz
+ sha256sums = a60c743cd4e0ef188e97f0c4fa841729eff11cf9812711581b98cec47cab73a5
+
+pkgname = python-trytond_company
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1eb6a87475fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.xz
+*.tar.gz
+*.asc
+/src
+/pkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b929790ef2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Martin Scholz <scholz.m82@gmail.com>
+pkgname=python-trytond_company
+_name=trytond_company
+pkgver=5.2.0
+_pkgdir=5.2
+pkgrel=1
+pkgdesc="Tryton module with companies and employees"
+arch=('any')
+url="http://www.tryton.org/"
+license=('GPL3')
+depends=('python>=3.5')
+makedepends=('python-distribute')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a60c743cd4e0ef188e97f0c4fa841729eff11cf9812711581b98cec47cab73a5')
+
+build() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}