summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin 'golodhrim' Scholz2019-07-14 17:37:34 +0200
committerMartin 'golodhrim' Scholz2019-07-14 17:37:34 +0200
commit0629bdaa9421f4e00bebf5da9464e06d6b9a204d (patch)
tree6a18bb1b447d31814f859b290419e38876c815ca
downloadaur-0629bdaa9421f4e00bebf5da9464e06d6b9a204d.tar.gz
adding module python-trytond_ldap_authentication for trytond
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af71e5f2e50d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-trytond_ldap_authentication
+ pkgdesc = Tryton module to authenticate users through LDAP
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = http://www.tryton.org/
+ arch = any
+ license = GPL3
+ makedepends = python-distribute
+ depends = python>=3.5
+ source = https://files.pythonhosted.org/packages/source/t/trytond_ldap_authentication/trytond_ldap_authentication-5.2.0.tar.gz
+ sha256sums = e426e04fe1b1885a73a910256102622e57b2d4fd476d956b571d00fa59971c61
+
+pkgname = python-trytond_ldap_authentication
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1eb6a87475fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.xz
+*.tar.gz
+*.asc
+/src
+/pkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b933b0986d3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Martin Scholz <scholz.m82@gmail.com>
+pkgname=python-trytond_ldap_authentication
+_name=trytond_ldap_authentication
+pkgver=5.2.0
+_pkgdir=5.2
+pkgrel=1
+pkgdesc="Tryton module to authenticate users through LDAP"
+arch=('any')
+url="http://www.tryton.org/"
+license=('GPL3')
+depends=('python>=3.5')
+makedepends=('python-distribute')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e426e04fe1b1885a73a910256102622e57b2d4fd476d956b571d00fa59971c61')
+
+build() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}