summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2023-05-28 03:10:17 +0200
committerBrainDamage2023-05-28 03:10:17 +0200
commit55418c5de4696903058e3555cb158bb8bc6308a6 (patch)
treed7c83069e8651616445dfebc4b3a8744792c430d
parent673c29e1f1120b2afbf4428cf2d7c41ca80409c3 (diff)
downloadaur-55418c5de4696903058e3555cb158bb8bc6308a6.tar.gz
version bump
switched build system from setuptools to pyproject and wheels
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0edb158d4465..8e750d944dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-tulir-telethon
pkgdesc = is a fork of Telethon library with custom patches from Tulir.
- pkgver = 1.28.0a3
+ pkgver = 1.28.0a9
pkgrel = 1
url = https://github.com/tulir/Telethon
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-pyaes
depends = python-rsa
depends = python
@@ -15,7 +17,7 @@ pkgbase = python-tulir-telethon
optdepends = python-pillow
provides = python-telethon
conflicts = python-telethon
- source = https://files.pythonhosted.org/packages/source/t/tulir-telethon/tulir-telethon-1.28.0a3.tar.gz
- sha256sums = 3755d01a98dfc94a9c4fe6ec481c42e4fbabbe777ffb837357332189aab9c83a
+ source = https://files.pythonhosted.org/packages/source/t/tulir-telethon/tulir-telethon-1.28.0a9.tar.gz
+ sha256sums = ee5468258872f5cf11c494d6d7fed2acdb40dfa9b022b3dcc9130f54d8562539
pkgname = python-tulir-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 1fcfec10e61c..d1035dde1cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: BrainDamage
pkgname=python-tulir-telethon
-pkgver=1.28.0a3
+pkgver=1.28.0a9
pkgrel=1
pkgdesc="is a fork of Telethon library with custom patches from Tulir."
arch=('any')
@@ -12,7 +12,7 @@ provides=('python-telethon')
conflicts=('python-telethon')
optdepends=('python-cryptg' 'python-pysocks' 'python-hachoir' 'python-pillow')
-sha256sums=('3755d01a98dfc94a9c4fe6ec481c42e4fbabbe777ffb837357332189aab9c83a')
+sha256sums=('ee5468258872f5cf11c494d6d7fed2acdb40dfa9b022b3dcc9130f54d8562539')
_dirname="${pkgname#python-}-${pkgver}"
_basename="${pkgname#python-}"
@@ -21,20 +21,22 @@ _basename="${pkgname#python-}"
source=("https://files.pythonhosted.org/packages/source/${_basename::1}/${_basename}/${_basename}-${pkgver}.tar.gz")
# template end;
-# template start; name=python; version=1;
+# template start; name=python-wheel; version=1;
depends+=('python')
-makedepends+=('python-setuptools')
+makedepends+=(python-build python-installer python-wheel)
build() {
cd "${srcdir}/${_dirname}"
export PYTHONHASHSEED=0
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_dirname}"
- python setup.py install --optimize=1 --skip-build --root="${pkgdir}/" --prefix="/usr"
+ find dist -name '*.whl' -exec python -m installer --compile-bytecode 1 --destdir="${pkgdir}" {} \;
# not necessary for every package, but for those who it is, it'd generate conflict with others otherwise
rm -rf "${pkgdir}/$(python -c 'import site; print(site.getsitepackages()[0])')/tests/"
+ find . -maxdepth 1 -iname 'README*' -exec install -Dvm 644 {} -t "${pkgdir}/usr/share/doc/${_basename}" \;
+ find . -maxdepth 1 -iname 'LICENSE*' -exec install -Dvm 644 {} -t "${pkgdir}/usr/share/licenses/${_basename}" \;
}
# template end;