summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoretckeeper2022-04-18 01:29:59 +0200
committeretckeeper2022-04-18 01:29:59 +0200
commit9246f5705a032283cf504b0f72941dde5a503dfa (patch)
tree056c6151b94d4e41eb176571052e37a4a3241436
downloadaur-9246f5705a032283cf504b0f72941dde5a503dfa.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ed17d0bcc89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-tulir-telethon
+ pkgdesc = is a fork of Telethon library with custom patches from Tulir.
+ pkgver = 1.25.0a7
+ pkgrel = 1
+ url = https://github.com/tulir/Telethon
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pyaes
+ depends = python-rsa
+ depends = python
+ optdepends = python-cryptg
+ optdepends = python-pysocks
+ optdepends = python-hachoir
+ optdepends = python-pillow
+ provides = python-telethon
+ conflicts = python-telethon
+ source = https://files.pythonhosted.org/packages/source/t/tulir-telethon/tulir-telethon-1.25.0a7.tar.gz
+ sha256sums = fb01d1ac196e3347a37478c8bd2936f303887c27c8ca26c1726c06fe4b1b89a7
+
+pkgname = python-tulir-telethon
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faae0dac915e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: BrainDamage
+
+pkgname=python-tulir-telethon
+pkgver=1.25.0a7
+pkgrel=1
+pkgdesc="is a fork of Telethon library with custom patches from Tulir."
+arch=('any')
+url="https://github.com/tulir/Telethon"
+license=('MIT')
+depends=('python-pyaes' 'python-rsa')
+provides=('python-telethon')
+conflicts=('python-telethon')
+optdepends=('python-cryptg' 'python-pysocks' 'python-hachoir' 'python-pillow')
+
+sha256sums=('fb01d1ac196e3347a37478c8bd2936f303887c27c8ca26c1726c06fe4b1b89a7')
+
+_dirname="${pkgname#python-}-${pkgver}"
+_basename="${pkgname#python-}"
+
+# template start; name=pythonhosted; version=1;
+source=("https://files.pythonhosted.org/packages/source/${_basename::1}/${_basename}/${_basename}-${pkgver}.tar.gz")
+# template end;
+
+# template start; name=python; version=1;
+depends+=('python')
+makedepends+=('python-setuptools')
+
+build() {
+ cd "${srcdir}/${_dirname}"
+ export PYTHONHASHSEED=0
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_dirname}"
+ python setup.py install --optimize=1 --skip-build --root="${pkgdir}/" --prefix="/usr"
+ # not necessary for every package, but for those who it is, it'd generate conflict with others otherwise
+ rm -rf "${pkgdir}/$(python -c 'import site; print(site.getsitepackages()[0])')/tests/"
+}
+# template end;