summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-06-22 17:15:17 +0200
committerwillemw122021-06-22 17:15:17 +0200
commit2a27bc0540a0d046377245105653926013b56cf6 (patch)
tree8ffdc994c5bb07b2e35ab4cbae3995616455a927
parent77dacf65435326932a58bf18f5f4c6e3bb0e72b5 (diff)
downloadaur-2a27bc0540a0d046377245105653926013b56cf6.tar.gz
Change source URL from git:// to git+https://
Minor edits
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39c5370e02ce..8c2f61588ed0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tvdb_api-git
pkgdesc = Easy to use interface to thetvdb.com
- pkgver = 1.9.r25.g8f34a0d
+ pkgver = 3.1.r2.gd2705e6
pkgrel = 1
url = https://github.com/dbr/tvdb_api
arch = any
@@ -10,8 +10,7 @@ pkgbase = python-tvdb_api-git
depends = python-requests-cache
provides = python-tvdb_api
conflicts = python-tvdb_api
- source = python-tvdb_api::git://github.com/dbr/tvdb_api.git
+ source = python-tvdb_api-git::git+https://github.com/dbr/tvdb_api.git
md5sums = SKIP
pkgname = python-tvdb_api-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 993f526f10e0..b77127095c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: willemw <willemw12@gmail.com>
# Contributor: Clément Démoulins <clement@archivel.fr>
-_pkgname=python-tvdb_api
-pkgname=$_pkgname-git
-pkgver=1.9.r25.g8f34a0d
+pkgname=python-tvdb_api-git
+pkgver=3.1.r2.gd2705e6
pkgrel=1
pkgdesc="Easy to use interface to thetvdb.com"
arch=('any')
@@ -11,23 +10,23 @@ url="https://github.com/dbr/tvdb_api"
license=('GPL')
depends=('python-requests-cache')
makedepends=('git' 'python-setuptools')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($_pkgname::git://github.com/dbr/tvdb_api.git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::git+$url.git)
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd $pkgname
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $_pkgname
+ cd $pkgname
python setup.py build
}
package() {
- cd $_pkgname
+ cd $pkgname
python setup.py install --root="$pkgdir/" --optimize=1
}