summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-08-30 10:40:30 +0200
committerwillemw122016-08-30 10:40:30 +0200
commitc332160b6f858572d928b109b2301d10fe3b2048 (patch)
tree3dcf034ad20b726ecc3d73fe76ccf94fa4861c87
downloadaur-c332160b6f858572d928b109b2301d10fe3b2048.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f06fa01b5ddb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-tvdb_api-git
+ pkgdesc = Easy to use interface to thetvdb.com
+ pkgver = 1.9.r25.g8f34a0d
+ pkgrel = 1
+ url = https://github.com/8cylinder/tv-overlord
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-requests-cache
+ provides = python-tvdb_api
+ provides = tvdb_api
+ conflicts = python-tvdb_api
+ conflicts = tvdb_api
+ source = python-tvdb_api::git://github.com/dbr/tvdb_api.git
+ md5sums = SKIP
+
+pkgname = python-tvdb_api-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38d722b0c15c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Clément Démoulins <clement@archivel.fr>
+
+_pkgname=python-tvdb_api
+pkgname=$_pkgname-git
+pkgver=1.9.r25.g8f34a0d
+pkgrel=1
+pkgdesc="Easy to use interface to thetvdb.com"
+arch=('any')
+url="https://github.com/8cylinder/tv-overlord"
+license=('GPL')
+depends=('python-requests-cache')
+makedepends=('git' 'python-setuptools')
+provides=($_pkgname 'tvdb_api')
+conflicts=($_pkgname 'tvdb_api')
+source=($_pkgname::git://github.com/dbr/tvdb_api.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+