summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-20 22:24:56 -0500
committerclintval2017-12-20 22:24:56 -0500
commitdc3eb20f1871c7a6f66f87951115637de2b69fa2 (patch)
treec16146bbf5697ee45c86f96f4e9a6ae113e0c0f8
downloadaur-dc3eb20f1871c7a6f66f87951115637de2b69fa2.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e127f01d44b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-typechecks
+ pkgdesc = Helper functions for runtime type checking
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/typechecks
+ arch = any
+ license = Apache-2.0
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/60/8e/ca9aac318aeb8e909b4435881c79a633ed40e4efa6fbb3c32c393b5da512/typechecks-0.0.2.tar.gz
+ md5sums = 07501491d2f9e7a67889df15be1b1ea8
+
+pkgname = python-typechecks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5b129c47d71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-typechecks'
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Helper functions for runtime type checking"
+arch=('any')
+url="https://pypi.python.org/pypi/typechecks"
+license=('Apache-2.0')
+depends=('python')
+optdepends=()
+makedepends=('python-setuptools')
+ptions=(!emptydirs)
+source=("https://pypi.python.org/packages/60/8e/ca9aac318aeb8e909b4435881c79a633ed40e4efa6fbb3c32c393b5da512/typechecks-${pkgver}.tar.gz")
+md5sums=('07501491d2f9e7a67889df15be1b1ea8')
+
+package() {
+ cd "${srcdir}/typechecks-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}