summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvan Chen2022-12-25 20:40:42 -0500
committerEvan Chen2022-12-25 20:43:22 -0500
commit6d80fbb0560d0b64f093573e25e43c3fb56394c7 (patch)
treef45de9d3e4b877b90c31be993f082677d8b51ece
parentbe52b8fb0c22df4808f53257cfec73568dbad7b1 (diff)
downloadaur-6d80fbb0560d0b64f093573e25e43c3fb56394c7.tar.gz
Simplify PKGBUILD yochananmarqos
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD139
-rw-r--r--PKGBUILD_EXTRAS0
3 files changed, 17 insertions, 135 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26f7784c0681..e45e88d0d33b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,14 +5,11 @@ pkgbase = python-types-markdown
url = https://github.com/python/typeshed
arch = any
license = Apache
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- noextract = types_Markdown-3.4.2.1-py3-none-any.whl
- source = PKGBUILD_EXTRAS
- source = https://files.pythonhosted.org/packages/48/65/d7bea36fadce0ba07e362defb2545f7e323c0f8876d5929b0c23b98d8822/types_Markdown-3.4.2.1-py3-none-any.whl
- source = LICENSE
- md5sums = SKIP
- md5sums = 7f51213faa171b1d8d2a8639524083d5
- md5sums = 84cbb431042e656c3ccddf7f5ecc2d84
+ source = https://files.pythonhosted.org/packages/source/t/types-Markdown/types-Markdown-3.4.2.1.tar.gz
+ sha256sums = 03c0904cf5886a7d8193e2f50bcf842afc89e0ab80f060f389f6c2635c65628f
pkgname = python-types-markdown
diff --git a/PKGBUILD b/PKGBUILD
index 946d7d945906..a1266366e68c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,139 +1,24 @@
# Maintainer: Evan Chen <evan@evanchen.cc>
-export PIP_CONFIG_FILE=/dev/null
-export PIP_DISABLE_PIP_VERSION_CHECK=true
-
pkgname=python-types-markdown
-epoch=
+_name=types-Markdown
pkgver=3.4.2.1
pkgrel=00
pkgdesc='Typing stubs for Markdown'
arch=(any)
url=https://github.com/python/typeshed
license=(Apache)
-depends=(python )
-## EXTRA_DEPENDS ##
-makedepends=(python-pip)
-checkdepends=()
-provides=()
-conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
-source=(PKGBUILD_EXTRAS)
-md5sums=(SKIP)
-noextract=()
-source+=(https://files.pythonhosted.org/packages/48/65/d7bea36fadce0ba07e362defb2545f7e323c0f8876d5929b0c23b98d8822/types_Markdown-3.4.2.1-py3-none-any.whl)
-md5sums+=(7f51213faa171b1d8d2a8639524083d5)
-noextract+=(types_Markdown-3.4.2.1-py3-none-any.whl)
-source+=(LICENSE)
-md5sums+=(84cbb431042e656c3ccddf7f5ecc2d84)
-
-_first_source() {
- echo " ${source_i686[@]} ${source_x86_64[@]} ${source[@]}" |
- tr ' ' '\n' | grep -Pv '^(PKGBUILD_EXTRAS)?$' | head -1
-}
-
-_vcs="$(grep -Po '^[a-z]+(?=\+)' <<< "$(_first_source)")"
-if [[ "$_vcs" ]]; then
- makedepends+=("$(pkgfile --quiet /usr/bin/$_vcs)")
- provides+=("${pkgname%-$_vcs}")
- conflicts+=("${pkgname%-$_vcs}")
-fi
-
-_is_wheel() {
- [[ $(_first_source) =~ \.whl$ ]]
-}
-
-if [[ _is_wheel &&
- $(basename "$(_first_source)" | rev | cut -d- -f1 | rev) =~ ^manylinux ]]; then
- options=(!strip) # https://github.com/pypa/manylinux/issues/119
-fi
-
-_dist_name() {
- find "$srcdir" -mindepth 1 -maxdepth 1 -type d -printf '%f
-' |
- grep -v '^_tmpenv$'
-}
-
-if [[ $(_first_source) =~ ^git+ ]]; then
- _pkgver() {
- ( set -o pipefail
- cd "$srcdir/$(_dist_name)"
- git describe --long --tags 2>/dev/null |
- sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
- }
-
- pkgver() { _pkgver; }
-fi
-
-_build() {
- if _is_wheel; then return; fi
- cd "$srcdir"
- # See Arch Wiki/PKGBUILD/license.
- # Get the first filename that matches.
- local test_name
- if [[ ${license[0]} =~ ^(BSD|MIT|ZLIB|Python)$ ]]; then
- for test_name in LICENSE LICENSE.txt license.txt COPYING COPYING.md COPYING.rst COPYING.txt COPYRIGHT; do
- if cp "$srcdir/$(_dist_name)/$test_name" "$srcdir/LICENSE" 2>/dev/null; then
- break
- fi
- done
- fi
- # Use the latest version of pip, as Arch's version is historically out of
- # date(!) and newer versions do fix bugs (sometimes).
- python -mvenv --clear --system-site-packages _tmpenv
- _tmpenv/bin/pip --quiet install -U pip
- # Build the wheel (which we allow to fail) only after fetching the license.
- # In order to isolate from ~/.pydistutils.cfg, we need to set $HOME to a
- # temporary directory, and thus first $XDG_CACHE_HOME back to its real
- # location, so that pip inserts the wheel in the wheel cache. We cannot
- # use --global-option=--no-user-cfg instead because that fully disables
- # wheels, causing a from-source build of build dependencies such as
- # numpy/scipy.
- XDG_CACHE_HOME="${XDG_CACHE_HOME:-"$HOME/.cache"}" HOME=_tmpenv \
- _tmpenv/bin/pip wheel -v --no-deps --wheel-dir="$srcdir" \
- "./$(_dist_name)" || true
+depends=(python)
+makedepends=(python-build python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('03c0904cf5886a7d8193e2f50bcf842afc89e0ab80f060f389f6c2635c65628f')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
-build() { _build; }
-
-_check() {
- # Define check(), possibly using _check as a helper, to run the tests.
- # You may need to call `python setup.py build_ext -i` first.
- if _is_wheel; then return; fi
- cd "$srcdir/$(_dist_name)"
- /usr/bin/python setup.py -q test
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-
-_package() {
- cd "$srcdir"
- # pypa/pip#3063: pip always checks for a globally installed version.
- python -mvenv --clear --system-site-packages _tmpenv
- _tmpenv/bin/pip install --prefix="$pkgdir/usr" \
- --no-deps --ignore-installed --no-warn-script-location \
- "$(ls ./*.whl 2>/dev/null || echo ./"$(_dist_name)")"
- if [[ -d "$pkgdir/usr/bin" ]]; then # Fix entry points.
- for f in "$pkgdir/usr/bin/"*; do
- if [[ $(head -n1 "$f") = "#!$(readlink -f _tmpenv)/bin/python" ]]; then
- sed -i '1c#!/usr/bin/python' "$f"
- fi
- done
- fi
- if [[ -d "$pkgdir/usr/etc" ]]; then
- mv "$pkgdir/usr/etc" "$pkgdir/etc"
- fi
- if [[ -f LICENSE ]]; then
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- fi
-}
-
-package() { _package; }
-
-. "$(dirname "$BASH_SOURCE")/PKGBUILD_EXTRAS"
-
-# Remove makedepends already in depends (which may have been listed for the
-# first build, but autodetected on the second.
-makedepends=($(printf '%s\n' "${makedepends[@]}" |
- grep -Pwv "^($(IFS='|'; echo "${depends[*]}"))$"))
-: # Apparently ending with makedepends assignment sometimes fails.
diff --git a/PKGBUILD_EXTRAS b/PKGBUILD_EXTRAS
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/PKGBUILD_EXTRAS
+++ /dev/null