summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-05-24 14:33:39 -0400
committerGuillaume Horel2022-05-24 14:33:39 -0400
commit8a6b9a5be4110c2f47ddfc2aac9b8d25ab2e4a12 (patch)
tree822dd9bd699cd6653779a22057708ef373b77e36
downloadaur-8a6b9a5be4110c2f47ddfc2aac9b8d25ab2e4a12.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73bea127291f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ubelt
+ pkgdesc = A Python utility belt containing simple tools
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/Erotemic/ubelt
+ arch = any
+ license = Apache2
+ makedepends = python-setuptools
+ depends = python
+ depends = python-ordered-set
+ source = https://files.pythonhosted.org/packages/source/u/ubelt/ubelt-1.0.1.tar.gz
+ sha256sums = cc94626ea111f554f9cbdc8dede6cf83ec1f58ca1c49648d513022be05ba8a93
+
+pkgname = python-ubelt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1393b12fe480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=python-ubelt
+_pkgname=ubelt
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A Python utility belt containing simple tools"
+arch=('any')
+url="https://github.com/Erotemic/ubelt"
+license=('Apache2')
+depends=('python' 'python-ordered-set')
+optdepends=()
+makedepends=('python-setuptools')
+checkdepends=()
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('cc94626ea111f554f9cbdc8dede6cf83ec1f58ca1c49648d513022be05ba8a93')
+
+build(){
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package(){
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+
+### vim:ts=2:sw=2:et: