summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Schaf2015-06-08 20:27:07 +0200
committerPhil Schaf2015-06-08 20:27:07 +0200
commit01304c1fcf91f48194013f63c5c17abb987b15f6 (patch)
tree1680a5dd71dc64e6e506ddccecefec20e836b832
downloadaur-01304c1fcf91f48194013f63c5c17abb987b15f6.tar.gz
aur4 support
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92bde95c8764
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-ucnum
+ pkgdesc = Unicode helper and search utility
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://github.com/flying-sheep/ucnum
+ arch = any
+ license = GPLv3
+ depends = python
+ depends = python-unicodeblocks
+ optdepends = python-unicodedata2: Updated unicodedata
+ source = https://pypi.python.org/packages/source/u/ucnum/ucnum-1.1.tar.gz
+ md5sums = d67f0e2e203e39df140f70cb2046193d
+
+pkgname = python-ucnum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..766db2c481d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+_name=ucnum
+pkgname="python-$_name"
+pkgver=1.1
+pkgrel=1
+pkgdesc='Unicode helper and search utility'
+arch=('any')
+url="http://github.com/flying-sheep/$_name"
+license=('GPLv3')
+depends=('python' 'python-unicodeblocks')
+optdepends=('python-unicodedata2: Updated unicodedata')
+source=("https://pypi.python.org/packages/source/u/$_name/$_name-$pkgver.tar.gz")
+md5sums=('d67f0e2e203e39df140f70cb2046193d')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+} \ No newline at end of file