summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Schmiade2015-06-17 13:47:29 +0200
committerTimo Schmiade2015-06-17 13:47:29 +0200
commite1f68e9ce73d4708624750214f421a1a4d04d9b3 (patch)
tree3b006e65fa087b7d35c790efc384ac84cf48c53f
downloadaur-e1f68e9ce73d4708624750214f421a1a4d04d9b3.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0acd0092907b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-udcli
+ pkgdesc = udisks2 command-line interface with zsh completion, written in python3
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/the-isz/udcli
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-dbus
+ depends = udisks2
+ source = https://github.com/the-isz/udcli/archive/0.1.1.tar.gz
+ md5sums = 06b1ed71b13f0863148625bc46a54353
+
+pkgname = python-udcli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba90aa73c851
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Timo Schmiade <the_isz@gmx.de>
+pkgname=('python-udcli')
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="udisks2 command-line interface with zsh completion, written in python3"
+arch=('any')
+url="https://github.com/the-isz/udcli"
+license=('GPL')
+depends=('python' 'python-dbus' 'udisks2')
+makedepends=('git')
+source=("https://github.com/the-isz/udcli/archive/${pkgver}.tar.gz")
+md5sums=(06b1ed71b13f0863148625bc46a54353)
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/zsh/site-functions"
+
+ cd "$srcdir/udcli-$pkgver"
+ install -m 755 code/udcli "$pkgdir/usr/bin"
+ install -m 644 zsh/_udcli "$pkgdir/usr/share/zsh/site-functions"
+}