summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-03-12 16:23:57 +0300
committerCaleb Maclennan2022-03-12 16:23:57 +0300
commit6b220d0a470a559ce60bd3e2047ef0f885934748 (patch)
tree25d08b46c51fbf49079a2e773378c33fbdf14516
parentbb26bf3771978b10bc3599662d1bcb369004b301 (diff)
downloadaur-6b220d0a470a559ce60bd3e2047ef0f885934748.tar.gz
upgpkg: python-uharfbuzz 0.22.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46e2e708e56c..fb41c2f0a1cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = python-uharfbuzz
pkgdesc = Streamlined Cython bindings for the harfbuzz shaping engine
- pkgver = 0.21.0
+ pkgver = 0.22.0
pkgrel = 1
url = https://github.com/harfbuzz/
arch = x86_64
license = Apache
+ checkdepends = python-pytest
makedepends = cython
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools-scm
makedepends = python-scikit-build
+ makedepends = python-wheel
depends = python
- source = https://files.pythonhosted.org/packages/source/u/uharfbuzz/uharfbuzz-0.21.0.zip
- sha256sums = 01b9c463f876f426fdc6dffc8e7eef60d46546502d5ebc121e81dd6e003089e3
+ source = https://files.pythonhosted.org/packages/source/u/uharfbuzz/uharfbuzz-0.22.0.zip
+ sha256sums = 82b68867fffd78d84e664ee872a193a897a35f398e40095ede7759456da4ebb6
pkgname = python-uharfbuzz
diff --git a/PKGBUILD b/PKGBUILD
index a4142231825a..9883491a9171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pyname=uharfbuzz
pkgname=python-$_pyname
-pkgver=0.21.0
+pkgver=0.22.0
pkgrel=1
pkgdesc='Streamlined Cython bindings for the harfbuzz shaping engine'
arch=(x86_64)
@@ -10,23 +10,26 @@ url="https://github.com/harfbuzz/$_project"
license=(Apache)
depends=(python)
makedepends=(cython
+ python-{build,installer}
python-setuptools-scm
- python-scikit-build)
+ python-scikit-build
+ python-wheel)
+checkdepends=(python-pytest)
_archive="$_pyname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.zip")
-sha256sums=('01b9c463f876f426fdc6dffc8e7eef60d46546502d5ebc121e81dd6e003089e3')
+sha256sums=('82b68867fffd78d84e664ee872a193a897a35f398e40095ede7759456da4ebb6')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py test
+ pytest
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}