summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEkin Dursun2020-04-04 14:15:21 +0300
committerEkin Dursun2020-04-04 14:15:21 +0300
commit40e2643b43df258c3c5503887fa94e39ec08f688 (patch)
treec0a6b73842539589455947fd6c4f5c5d4da57a25
parentb1c528ed43a111c521a6c113a8c5159b1320afd5 (diff)
downloadaur-40e2643b43df258c3c5503887fa94e39ec08f688.tar.gz
Version bump
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb5fad4f68b2..ac23eb6e321e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,18 @@
pkgbase = python-uncompyle6
pkgdesc = Python byte-code disassembler and source-code converter.
- pkgver = 3.5.0
+ pkgver = 3.6.5
pkgrel = 1
url = https://github.com/rocky/python-uncompyle6/
arch = any
license = MIT
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/u/uncompyle6/uncompyle6-3.5.0.tar.gz
- sha256sums = 4e6e86c05de588cbf5a2c35ddd080f23cd1770a1ad15c84dc1b2c78d65113af7
-
-pkgname = python-uncompyle6
depends = python-spark-parser>=1.8.9
depends = python-spark-parser<1.9.0
- depends = python-xdis>=4.1.2
- depends = python-xdis<4.2.0
+ depends = python-xdis>=4.2.4
+ depends = python-xdis<4.3.0
+ source = https://files.pythonhosted.org/packages/source/u/uncompyle6/uncompyle6-3.6.5.tar.gz
+ sha256sums = ddbb2f9919464215fba4a7cc5522d1417e1e252d4940a11a6b3a888790d102ea
-pkgname = python2-uncompyle6
- depends = python2-spark-parser>=1.8.9
- depends = python2-spark-parser<1.9.0
- depends = python2-xdis>=4.1.2
- depends = python2-xdis<4.2.0
+pkgname = python-uncompyle6
diff --git a/PKGBUILD b/PKGBUILD
index bd3bd5d5b8d4..7ba5b8ed6ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,19 @@
# Contributor: Oliver Mangold omangold at gmail dot com
_name=uncompyle6
-pkgbase="python-${_name}"
-pkgname=("python-${_name}" "python2-${_name}")
-pkgver=3.5.0
+pkgname="python-${_name}"
+pkgver=3.6.5
pkgrel=1
pkgdesc="Python byte-code disassembler and source-code converter."
arch=('any')
url="https://github.com/rocky/python-uncompyle6/"
license=('MIT')
+depends=('python-spark-parser>=1.8.9' 'python-spark-parser<1.9.0' 'python-xdis>=4.2.4' 'python-xdis<4.3.0')
makedepends=('python-setuptools' 'python2-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('4e6e86c05de588cbf5a2c35ddd080f23cd1770a1ad15c84dc1b2c78d65113af7')
-
-package_python-uncompyle6() {
- depends=('python-spark-parser>=1.8.9' 'python-spark-parser<1.9.0' 'python-xdis>=4.1.2' 'python-xdis<4.2.0')
+sha256sums=('ddbb2f9919464215fba4a7cc5522d1417e1e252d4940a11a6b3a888790d102ea')
+package() {
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}
-
-package_python2-uncompyle6() {
- depends=('python2-spark-parser>=1.8.9' 'python2-spark-parser<1.9.0' 'python2-xdis>=4.1.2' 'python2-xdis<4.2.0')
-
- cd "$srcdir/$_name-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
- mv "$pkgdir/usr/bin/uncompyle6" "$pkgdir/usr/bin/uncompyle62"
- mv "$pkgdir/usr/bin/pydisassemble" "$pkgdir/usr/bin/pydisassemble2"
-}