summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-06-18 13:44:48 +0200
committerCarl Smedstad2023-06-18 13:49:01 +0200
commit2d811ece88784f715d36289e554512f43d606e0e (patch)
tree046f1fb814f9f416d4c564a319b11472afc00404
downloadaur-2d811ece88784f715d36289e554512f43d606e0e.tar.gz
Publish version 3.5.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab55147a8fef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-undetected-chromedriver
+ pkgdesc = Custom Selenium Chromedriver that passes all bot mitigation systems
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://github.com/ultrafunkamsterdam/undetected-chromedriver
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-selenium
+ depends = python-websockets
+ source = python-undetected-chromedriver-3.5.0.tar.gz::https://github.com/ultrafunkamsterdam/undetected-chromedriver/archive/2b035b4ea1d88224abd570b187f16094663462a3.tar.gz
+ sha256sums = 4db117ffa73787d9eba598ac5270bf9d03e5ba1824e0cf06325324ddf4455982
+
+pkgname = python-undetected-chromedriver
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..054eb0572de8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+
+pkgname=python-undetected-chromedriver
+_name=${pkgname#python-}
+pkgver=3.5.0
+_commit_hash=2b035b4ea1d88224abd570b187f16094663462a3
+pkgrel=1
+pkgdesc="Custom Selenium Chromedriver that passes all bot mitigation systems"
+arch=(any)
+url="https://github.com/ultrafunkamsterdam/undetected-chromedriver"
+license=(GPL3)
+depends=(
+ python-requests
+ python-selenium
+ python-websockets
+)
+makedepends=(
+ python-setuptools
+)
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/${_commit_hash}.tar.gz")
+sha256sums=('4db117ffa73787d9eba598ac5270bf9d03e5ba1824e0cf06325324ddf4455982')
+
+_archive="$_name-$_commit_hash"
+
+build() {
+ cd "$_archive"
+
+ python setup.py build
+}
+
+package() {
+ cd "$_archive"
+
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}