summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-04-15 13:25:03 -0500
committerLuis Martinez2022-04-15 13:25:03 -0500
commit08c83d37130b0642c44460c71cece9fbfc4d4a8b (patch)
tree3036aca905cd9faf107b0688462e33821d7f4a02
parent1552d6590293318f2a2c1bc54aead7c142def33b (diff)
downloadaur-08c83d37130b0642c44460c71cece9fbfc4d4a8b.tar.gz
package cleanup
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD49
2 files changed, 25 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db46a955ba67..213f3e036512 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-unicodecsv
- pkgdesc = A drop-in replacement for the csv module that supports unicode strings
+ pkgdesc = Drop-in replacement for the csv module that supports unicode strings
pkgver = 0.14.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/jdunck/python-unicodecsv
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
- source = https://files.pythonhosted.org/packages/source/u/unicodecsv/unicodecsv-0.14.1.tar.gz
+ source = python-unicodecsv-0.14.1.tar.gz::https://files.pythonhosted.org/packages/source/u/unicodecsv/unicodecsv-0.14.1.tar.gz
source = https://raw.githubusercontent.com/jdunck/python-unicodecsv/master/LICENSE
sha256sums = 018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc
sha256sums = a3b3fcd3f2b3e97b4c4ffc354f719e1519dc95dc0b09d82f769538feeb7db032
pkgname = python-unicodecsv
-
diff --git a/PKGBUILD b/PKGBUILD
index 837d8718e602..6395c6a6a52f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,29 @@
-# Maintainer: peippo <christoph+aur@christophfink.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: peippo <christoph+aur@christophfink.com>
-pkgname="python-unicodecsv"
+pkgname=python-unicodecsv
_name=${pkgname#python-}
-pkgdesc="A drop-in replacement for the csv module that supports unicode strings"
-url="https://github.com/jdunck/python-unicodecsv"
-
+pkgdesc="Drop-in replacement for the csv module that supports unicode strings"
pkgver=0.14.1
-pkgrel=3
-
-arch=("any")
-license=("BSD")
-
-makedepends=(
- "python-setuptools"
-)
-depends=(
- "python"
-)
-
+pkgrel=4
+arch=('any')
+license=('BSD')
+url="https://github.com/jdunck/python-unicodecsv"
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=(
- "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/jdunck/python-unicodecsv/master/LICENSE"
-)
-sha256sums=(
- "018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc"
- "a3b3fcd3f2b3e97b4c4ffc354f719e1519dc95dc0b09d82f769538feeb7db032"
-)
+ "$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/jdunck/python-unicodecsv/master/LICENSE")
+sha256sums=('018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc'
+ 'a3b3fcd3f2b3e97b4c4ffc354f719e1519dc95dc0b09d82f769538feeb7db032')
build() {
- cd "${srcdir}"/${_name}-${pkgver}
- python setup.py build
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "$_name-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}