summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkewl fft2022-03-09 15:25:45 +0000
committerkewl fft2022-03-09 15:25:45 +0000
commite1b1ef674c56a9e6f152fb225f1d77fe61ffb5db (patch)
treee14bc6fab1479e08b1c8ece2b4796d08171f16d8
downloadaur-e1b1ef674c56a9e6f152fb225f1d77fe61ffb5db.tar.gz
Update to version 1.39.0-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD24
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc3f6049a300
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-unicorn-binance-websocket-api
+ pkgdesc = An unofficial Python API to use the Binance REST API
+ pkgver = 1.39.0
+ pkgrel = 1
+ url = https://github.com/LUCIT-Systems-and-Development/unicorn-binance-websocket-api
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-cheroot
+ depends = python-colorama
+ depends = python-flask
+ depends = python-flask-restful
+ depends = python-psutil
+ depends = python-requests
+ depends = python-ujson
+ depends = python-unicorn-fy
+ depends = python-websocket-client
+ depends = python-websockets
+ source = python-unicorn-binance-websocket-api-1.39.0.tar.gz::https://github.com/LUCIT-Systems-and-Development/unicorn-binance-websocket-api/archive/1.39.0.tar.gz
+ sha256sums = 437664e0359d8ef264663f54ab5c00678f50c8eb6b357418ef00e0d3e6fadd03
+
+pkgname = python-unicorn-binance-websocket-api
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07b46466e19f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
+
+pkgname="python-unicorn-binance-websocket-api"
+_pkgname=${pkgname#python-}
+pkgver=1.39.0
+pkgrel=1
+pkgdesc="An unofficial Python API to use the Binance REST API"
+arch=('any')
+url="https://github.com/LUCIT-Systems-and-Development/$_pkgname"
+license=('MIT')
+depends=('python-cheroot' 'python-colorama' 'python-flask' 'python-flask-restful' 'python-psutil' 'python-requests' 'python-ujson' 'python-unicorn-fy' 'python-websocket-client' 'python-websockets')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('437664e0359d8ef264663f54ab5c00678f50c8eb6b357418ef00e0d3e6fadd03')
+
+build() {
+ cd $_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}