summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2023-06-26 15:10:06 +0100
committerWill Handley2023-06-26 15:10:06 +0100
commitbfcf14e6e3e40a964de3865341d6ded2d945c52b (patch)
treea3be493bb0502b8bf744a16c1bd9a35ac47840cb
downloadaur-bfcf14e6e3e40a964de3865341d6ded2d945c52b.tar.gz
0.0.0
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dff7e7f0fd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-unimpeded
+ pkgdesc = Universal model comparison & parameter estimation over diverse datasets
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/handley-lab/unimpeded
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-pandas
+ provides = unimpeded
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/u/unimpeded/unimpeded-0.0.0.tar.gz
+ sha256sums = c0e191e8f448bc570223be573d30aece75b205e058ba97f7b3489990bb268333
+
+pkgname = python-unimpeded
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6b8c850ccb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.tar.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6e8692df694
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-unimpeded
+_name=${pkgname#python-}
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="Universal model comparison & parameter estimation over diverse datasets"
+arch=(any)
+url="https://github.com/handley-lab/unimpeded"
+license=(MIT)
+groups=()
+depends=(python-numpy python-matplotlib python-scipy python-pandas)
+makedepends=(python-build python-installer)
+provides=(unimpeded)
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(c0e191e8f448bc570223be573d30aece75b205e058ba97f7b3489990bb268333)
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+