summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-03-16 20:51:16 +0000
committerGrey Christoforo2020-03-16 20:51:16 +0000
commitb9b208d87d73ecd9353ac677b67470573bc89511 (patch)
tree489e46845303e1374f5d93cbe59429c1e7d1a934
downloadaur-b9b208d87d73ecd9353ac677b67470573bc89511.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72dd95acd78d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-unitypy-git
+ pkgdesc = A unity asset extractor based on unitypack and AssetStudio.
+ pkgver = r76.0182226
+ pkgrel = 1
+ url = https://github.com/K0lb3/UnityPy
+ arch = x86_64
+ license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ depends = brotli
+ depends = python-pillow
+ depends = python-fsb5
+ depends = python-tex2img
+ provides = python-unitypy
+ conflicts = python-unitypy
+ source = git+https://github.com/K0lb3/UnityPy.git
+ md5sums = SKIP
+
+pkgname = python-unitypy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9150aaf5ddfa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+UnityPy/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a900536ced4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python-unitypy-git
+pkgver=r76.0182226
+pkgrel=1
+pkgdesc="A unity asset extractor based on unitypack and AssetStudio."
+arch=('x86_64')
+url="https://github.com/K0lb3/UnityPy"
+license=('MIT')
+provides=('python-unitypy')
+conflicts=('python-unitypy')
+depends=('brotli' 'python-pillow' 'python-fsb5' 'python-tex2img')
+checkdepends=('python-pytest' 'python-pytest-cov')
+
+source=("git+https://github.com/K0lb3/UnityPy.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd UnityPy
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd UnityPy
+ #pytest -v --cov
+ pytest -v --cov || true
+}
+
+package() {
+ cd UnityPy
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+