summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2020-05-06 11:04:31 -0700
committerDonald Webster2020-05-06 11:11:59 -0700
commit4500dce28944e3ad6f29816efd647838dda5bf19 (patch)
treea5515f41a7c2d90d925b3233b08ac119bf158518
downloadaur-4500dce28944e3ad6f29816efd647838dda5bf19.tar.gz
Initial version of python-unrar package.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89ee84585ffa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-unrar
+ pkgdesc = Push Notifications that work with just about every platform
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/davide-romanini/unrar
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = unrar
+ depends = python-unrardll
+ source = https://files.pythonhosted.org/packages/source/u/unrar/unrar-0.4.tar.gz
+ sha256sums = b24447a5b93024be600ef8255668ba23a30f451176577b691559ea1359f7d164
+
+pkgname = python-unrar
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..97484cf0bb87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.xz
+/*.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..378495dd7b5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+
+pkgname='python-unrar'
+_name=${pkgname#python-}
+pkgver=0.4
+pkgrel=1
+pkgdesc="Push Notifications that work with just about every platform"
+arch=('any')
+url="https://github.com/davide-romanini/unrar"
+license=('MIT')
+depends=(
+ 'unrar'
+ 'python-unrardll'
+)
+makedepends=(
+ 'python-setuptools'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('b24447a5b93024be600ef8255668ba23a30f451176577b691559ea1359f7d164')
+
+package() {
+ cd unrar-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: