summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-08-10 20:30:31 +1000
committerMatthew Gamble2015-08-10 20:30:31 +1000
commit9a096253a58e6636e11eef69d5858f03c94efb70 (patch)
treec79c701514af15c7a23e661e4b9b16c41116981c
downloadaur-9a096253a58e6636e11eef69d5858f03c94efb70.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88f7330d88fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-unstdlib
+ pkgdesc = Unstandard Python library of useful and highly-reusable functions.
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://github.com/shazow/unstdlib.py
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/source/u/unstdlib/unstdlib-1.7.tar.gz
+ sha256sums = 9348ff23b8f3a235db55b11e397d55352b2029e4fb0979558fee2d1ea8667280
+
+pkgname = python-unstdlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5101e85a5dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Matthew Gamble
+
+pkgname=python-unstdlib
+pkgver=1.7
+pkgrel=1
+pkgdesc="Unstandard Python library of useful and highly-reusable functions."
+arch=('any')
+url='https://github.com/shazow/unstdlib.py'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/source/u/unstdlib/unstdlib-$pkgver.tar.gz")
+sha256sums=('9348ff23b8f3a235db55b11e397d55352b2029e4fb0979558fee2d1ea8667280')
+
+build() {
+ cd "unstdlib-$pkgver"
+ tail -n 21 README > LICENSE
+}
+
+package() {
+ cd "unstdlib-$pkgver"
+ python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}