summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonion2023-07-10 11:24:44 -0600
committeranonion2023-07-10 11:24:44 -0600
commit56ab074612739892580a3eed7383c00eccebe2c3 (patch)
treefad37a3fdc7d0cc3e765b9cf6fd303898ae5c07b
downloadaur-56ab074612739892580a3eed7383c00eccebe2c3.tar.gz
initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3b352a8da27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-uptime-kuma-api
+ pkgdesc = A wrapper for the Uptime Kuma Socket.IO API
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/lucasheld/uptime-kuma-api
+ arch = any
+ license = MIT
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ depends = python-packaging
+ depends = python-socketio
+ source = uptime-kuma-api-1.1.0.tar.gz::https://github.com/lucasheld/uptime-kuma-api/archive/refs/tags/1.1.0.tar.gz
+ sha256sums = b564d4c5ca5308cf81a70615bd87c4804d14515e51e51169b8c58f27148846ff
+
+pkgname = python-uptime-kuma-api
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95fea3c7cd2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#Maintainer: anonion <aur at anonion dot social>
+
+pkgname=("python-uptime-kuma-api")
+_name=${pkgname#python-}
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A wrapper for the Uptime Kuma Socket.IO API"
+arch=('any')
+url="https://github.com/lucasheld/uptime-kuma-api"
+license=('MIT')
+depends=('python-packaging'
+ 'python-socketio')
+
+makedepends=('python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools')
+
+source=("${_name}-${pkgver}.tar.gz::https://github.com/lucasheld/uptime-kuma-api/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('b564d4c5ca5308cf81a70615bd87c4804d14515e51e51169b8c58f27148846ff')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}