summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Kubosz2018-07-29 20:33:57 +0200
committerRobert Kubosz2018-07-29 20:40:10 +0200
commite220c5118eaa8a216d95316c405759cbd4530923 (patch)
treecd1662cd2c26c35bff282727d22c726bbbe4cfcc
downloadaur-e220c5118eaa8a216d95316c405759cbd4530923.tar.gz
initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f8d86a0d4e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-uqbar
+ pkgdesc = Tools for building documentation with Sphinx, Graphviz and LaTeX
+ pkgver = 0.2.15
+ pkgrel = 1
+ url = https://github.com/josiah-wolf-oberholtzer/uqbar
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-sphinx
+ depends = python-unidecode
+ depends = python-sphinx_rtd_theme
+ depends = python-sphinx-autodoc-typehints
+ source = https://github.com/josiah-wolf-oberholtzer/uqbar/archive/v0.2.15.tar.gz
+ sha256sums = 292a8f10f5f7dbc33eb94b242640582dee069b8c8a19fcf70a728a8945161f90
+
+pkgname = python-uqbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab502bf97585
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
+
+pkgname=python-uqbar
+pkgver=0.2.15
+pkgrel=1
+pkgdesc='Tools for building documentation with Sphinx, Graphviz and LaTeX'
+arch=('any')
+url="https://github.com/josiah-wolf-oberholtzer/uqbar"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-sphinx'
+ 'python-unidecode'
+ 'python-sphinx_rtd_theme'
+ 'python-sphinx-autodoc-typehints'
+ )
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=("292a8f10f5f7dbc33eb94b242640582dee069b8c8a19fcf70a728a8945161f90")
+
+
+build() {
+ cd $srcdir/uqbar-$pkgver
+ python setup.py build
+}
+
+
+package() {
+ cd $srcdir/uqbar-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}