summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Wienke2021-10-02 19:17:38 +0200
committerJohannes Wienke2021-10-02 19:17:38 +0200
commit2a9ce3b803201b486763299dd7a5cdef57d85c0d (patch)
tree6fdc72850d881c591524baf898a8a26931e20006
parent6541acd86f6325cc85671f57a5f5ebac56827ae3 (diff)
downloadaur-2a9ce3b803201b486763299dd7a5cdef57d85c0d.tar.gz
ci: add a Gitlab CI config
-rw-r--r--.gitlab-ci.yml50
1 files changed, 50 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..371069b64b7c
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,50 @@
+build:
+ stage: build
+ image:
+ name: countstarlight/makepkg:latest
+ entrypoint: [""]
+ before_script:
+ - yay -Syu --noconfirm
+ script:
+ - |
+ depends=()
+ makedepends=()
+ checkdepends=()
+ . ./PKGBUILD
+ deps=( "${depends[@]}" "${makedepends[@]}" "${checkdepends[@]}" )
+ (pacman --deptest "${deps[@]}" || true) | xargs yay -Sy --noconfirm
+ - makepkg -f
+ artifacts:
+ untracked: false
+ expire_in: 5 days
+ paths:
+ - '*.pkg.tar.zst'
+
+test:
+ stage: test
+ image: archlinux:latest
+ script:
+ - pacman -Syu --noconfirm
+ - pacman --noconfirm -U *.pkg.tar.zst
+ - python -c "import uritools"
+
+deploy:
+ stage: deploy
+ image: bitnami/git:latest
+ rules:
+ - if: $CI_COMMIT_BRANCH == $CI_DEFAULT_BRANCH
+ variables:
+ GIT_DEPTH: "0"
+ before_script:
+ - mkdir -p ~/.ssh
+ - chmod 700 ~/.ssh
+
+ - ssh-keyscan aur.archlinux.org >> ~/.ssh/known_hosts
+ - chmod 644 ~/.ssh/known_hosts
+
+ - eval $(ssh-agent -s)
+ - echo "$SSH_PRIVATE_KEY" | tr -d '\r' | ssh-add -
+
+ script:
+ - git remote add aur ssh://aur@aur.archlinux.org/python-uritools.git
+ - git push aur origin/master:master